tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fernando González <fergo...@gmail.com>
Subject Tomcat 7.0.28 ignoring context copyXML attribute and web-fragments
Date Sun, 27 Sep 2015 22:16:46 GMT
Hi, I am using Tomcat 7.0.28 and I am deploying a .war with a context.xml
that sets the copyXML attribute to "true".

However, when I copy the war to the webapps folder, I get the following
message in catalina.out:

 "Setting property 'copyXML' to 'true' did not find a matching property."

and the context.xml will not be copied to conf/Catalina/localhost/.

Also the .war is being deployed without taking into account the
web-fragment.xml files but no error can be found on the log. I just get the
message for the undeploy, the deploy and the warning about no matching
property. To proof this: If I move the declarations from the web-fragments
to the web.xml the application gets deployed successfully. I also set the
logEffectiveWebXml property to true, obtaining a web.xml in the log with
none of the definitions from the fragments.

The same .war can be deployed on other Tomcat7 instances (in other
machines) without problems. The o.s. is a Debian 7 and the administrator
said he just installed tomcat from the debian package. The command "dpkg -s
tomcat7" gives me version 7.0.28.

Any hint about what can be wrong is very much appreciated.

Cheers.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message