tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Balažic <david.bala...@comtrade.com>
Subject RE: Firefox SSL with APR - losing client certificate
Date Mon, 10 Aug 2015 17:30:20 GMT
> From: David Balažic [mailto:david.balazic@comtrade.com]
> 
> > From: Christopher Schultz [mailto:chris@christopherschultz.net]
> > Sent: 8. August 2015 14:33
> >
> > Quick question: this is with Tomcat only and no httpd out in front, righ
> > t?
> 
> Yes.

It is also the same if run independently (without Eclipse):
 - extract apache-tomcat-6.0.44-windows-x64.zip
 - set JAVA_HOME,CATALINA_HOME, CATALINA_BASE and CATALINA_OPTS
 - copy war file into webapps folder
 - copy ojdbc6_g-11.2.0.2.0.jar into lib folder (my WAR uses an Oracle database)
 - execute startup.bat

Java is again 1.6.0_45 (x64).

It also happens with java version "1.8.0_51"
Java(TM) SE Runtime Environment (build 1.8.0_51-b16)
Java HotSpot(TM) 64-Bit Server VM (build 25.51-b03, mixed mode)


I also tested on another system with 32 bit Windows 7, apache-tomcat-6.0.44-windows-x86.zip
, with 
java version "1.6.0_12"
Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
Java HotSpot(TM) Client VM (build 11.2-b01, mixed mode, sharing)

Same problem (with FF, while IE works fine).

On the first system I also tried with Chrome: also has the problem.

Interestingly, on one occasion with FF the problem did not surface for long time (about 15
minutes of testing).
Then I cleared the "Active Logins" (shift-ctrl-del) in Firefox and tried again: the problem
occurred right on second HTTP(S) request.

Regards,
David

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message