tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Problem : Apache Tomcat 7.0 starts up fine using startup scripts; error when starting as Windows Service
Date Thu, 14 May 2015 18:39:05 GMT
> From: Troy Robinson [mailto:troy.robinson@sasktel.com] 
> Subject: Re: Problem : Apache Tomcat 7.0 starts up fine using startup scripts; 
> error when starting as Windows Service


> I had installed 32 bit Apache Tomcat 7.0.59 ... and 64-bit Java 7.

> It's interesting ... that Tomcat starts up fine, using the startup scripts
>... and the Application that I was installing Tomcat for ... also appears
> to be running fine.

Tomcat itself is pure Java (other than the optional APR connector), so it doesn't care whether
or not the JVM is 32- or 64-bit.  However, the mode of the service launcher must match that
of the installed JVM, since the launcher tries to load the JVM .dll into its own process.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message