tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jerry Malcolm <techst...@malcolms.com>
Subject Apparent Bug Introduced between 8.0.15 & 8.0.17
Date Thu, 05 Feb 2015 18:51:56 GMT
There is an apparent bug or functional change dealing with the sax 
package getting loaded that was introduced in 8.0.17.

Background: I have been in the process of migrating three independent 
servers to new hardware.  As part of the migration, I decided to upgrade 
all of them to the latest Tomcat 8.  The first one worked fine.  I 
repeated the install process on the 2nd one.  I kept getting an error on 
my pages, though, on the 2nd server install.  I decide to continue on to 
the third server while trying to figure out the problem.  The third 
server had the identical error.  The error message I received was:

--- javax.el.ELException: The package [org.saxpath] could not be found

I'm using JSTL, and the stack trace showed that it was occurring on a 
JSTL tag in a JSP.  Also, all three servers are Win Server 2008-R2.

I tried for several hours to figure out why a jar was apparently missing 
and/or what might be different from server #1.  I then noticed that I 
had downloaded Tomcat 8.0.15 for the first server and 8.0.17 for the 
other two servers.  Definitely a total long shot. But I uninstalled 
8.0.17 from the 2nd server and downloaded/installed 8.0.15 from the 
Tomcat archive.  Voila.... it works.  Did the same thing on the third 
server, and it fixed the problem there as well.

If this error message was the result of a bug that was introduced in 
8.0.17 that has been or will be corrected, then no problem. However, if 
this is a result of incompatibilities between my code and all future 
Tomcat releases, I want to figure it out now and get it resolved.  I 
definitely don't want to have to readdress this again when I decide to 
move up to Tomcat 9.x, etc.

Can anyone explain what changed?  BTW.... I'm using Apache Taglib 1.2.1 
jars, which as far I have been able to find, are the latest. Nothing 
else unique in what I'm doing in this area of the code as far as I can tell.

Thanks for any info you can provide.

Jerry

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message