tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Undeploy Error
Date Sun, 04 Jan 2015 16:13:04 GMT
On 03/01/2015 02:25, Mike Seda wrote:
> On 01/01/2015 09:35 AM, Mark Thomas wrote:
>> On 31/12/2014 22:38, Mike Seda wrote:
>>
>>> Please let us know what you think.
>> The information you provided doesn't add up.
>>
>> CATALINA_BASE:   /usr/local/tomcat
>> <Host appBase="webapps" ... />
>> -Dwebapp.path=/srv/tomcat/webapps/$1/
> 
> /usr/local/tomcat/webapps is a symlink to /srv/tomcat/webapps.

OK. Assuming those are both local file systems then that should work.
That it works most of the time suggests that the symlink isn't the issue
(although a non-local file system might be).

When undeployment fails, is the application still usable by clients?

>> The web application path you are providing to your build.xml (which we
>> have no way of knowing what it does)
> 
> /usr/local/tomcat-deployer/build.xml is the standard build.xml provided
> in the apache-tomcat-7.0.52-deployer tarball - obtained via the
> following link:
> http://tomcat.apache.org/download-70.cgi

OK.

The deployer uses JMX. The next step would be to connect a JMX client
and see if the deployed applications listed match what you expect when
you see one of these intermittent issues.

Is there any pattern to the names of the applications where you see this
issue? I'm just wondering if the path <-> JMX name translation is a
factor in this.

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message