tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Gamache <cgama...@gmail.com>
Subject Re: Help! parallel deployment problem.
Date Tue, 25 Nov 2014 03:55:04 GMT
So first, I'd be glad to. Just to be clear-- I'm not in need of a lecture,
but will willingly take one if anyone can help me get down to a solution.
My first attempt at asking for some assistance was met with crickets. I
haven't figured out why when I post (what I think are) well written, well
researched and discussion-provoking questions they get no traction but if I
cry "the sky is falling" folks are more willing to attempt to lend a hand.
Here's my go at attempt #3:

I have a tomcat cluster. It is set up with much care according to
http://tomcat.apache.org/tomcat-7.0-doc/cluster-howto.html.

It mostly works fine. On occasion (twice a week or so) there will be one or
more servers which didn't get the message that a new war was deployed
(continuous deployment using the tomcat parallel deployment scheme. e.g.
theapp##007.war) and they happily continue to run the old version of the
war.

In a farm deployment scenario, the master node will announce to the cluster
a new artifact is available and then the clustered tomcats will retrieve
and deploy the new artifact. I can't pin down the problem, but let just say
for argument's sake it is a true link-down situation. There doesn't seem to
exist a mechanism to re-announce, or announce at regular intervals. This
seems like a real weakness in the scheme. That makes me think I'm missing
something obvious. If it works like it says it should in the docs I
shouldn't be having this issue. Either there's something wrong with my
config or there's a problem with tomcat. Based on the hair I have left
after pulling mine out, I'm leaning toward a problem with tomcat. Is anyone
leveraging FarmWebDeployer and Parallel Deployment in their architecture
successfully? If so, DenverCoder9, what did you see?!?

TIA

P.S. the sky is falling :)



On Mon, Nov 24, 2014 at 7:36 PM, Leo Donahue <donahulf2@gmail.com> wrote:

> On Mon, Nov 24, 2014 at 5:48 PM, Chris Gamache <cgamache@gmail.com> wrote:
>
> > Tomcat 7 ... Working with parallel deployment, tomcat servers in my farm
> > are getting out-of-sync, not getting new versions of war files deployed
> to
> > the main tomcat. What could be going wrong and how can I fix it?
> >
> > Pleez Help!
> >
> Before anyone lectures you on your type of question and lack of specifics,
> re-submit a better question to get a better response.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message