tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Moore <wmoor...@gmail.com>
Subject Re: mod_jk on Mac OS X 10.10 (Yosemite)
Date Mon, 10 Nov 2014 21:26:04 GMT
Chris

The configure command is:

./configure CFLAGS='-arch x86_64' APXSLDFLAGS='-arch x86_64' --with-apxs=/usr/sbin/apxs

I also tried your version, and that gave the same error:
  
 configure: error: could not detect a 32-bit integer type

Which version of Xcode are you using? Mine says:
  
  Version 6.1 (6A1052d)

William

> On 10 Nov 2014, at 7:52pm, Christopher Schultz <chris@christopherschultz.net> wrote:
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
> 
> William,
> 
> On 11/10/14 10:50 AM, William Moore wrote:
>> Please can someone advise me how to build mod_jk on Mac OS X 10.10
>> (Yosemite / darwin 14.0.0)? I got past the failure at:
>> 
>> checking for gcc...
>> /Applications/Xcode.app/Contents/Developer/Toolchains/OSX10.10.xctoolchain/usr/bin/cc
>> 
>> 
> checking for C compiler default output file name... configure: error: C
> compiler cannot create executables
> 
> At some point in the recent past, Apple broke the command-line
> toolchains by renaming
> /Applications/Xcode.app/Contents/Developer/Toolchains/OSX[verision].xctoolchain
> to
> /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain.
> 
> If you in fact have an XcodeDefault.xctoolchain directory in
> Developer/Toolchains and you *don't* have the version-specific one,
> then just go in there and create a symlink:
> 
> $ cd /Applications/Xcode.app/Contents/Developer/Toolchains
> $ sudo ln -s XcodeDefault.xctoolchain OSX10.10.xctoolchain
> 
> This is probably how you fixed yours already. Another way to do it
> *should be* to just do this:
> 
> $
> CC=Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain
> ./configure --with-apxs=`which apxs`
> 
> On my system, configure completes and gives me a warning that I've
> overridden the compiler setting sniffed from apxs and warns me that I
> might get errors later.
> 
> When I try to actually build, libtool does not use the CC specified
> during configure. :(
> 
> So you have to go back to the whole symlink thing.
> 
> FWIW, I just built mod_jk 1.2.37 (the source I had available) on my
> machine running 10.10 after solving the toolchain thing. No problem
> with a 32-bit integer or anything like that.
> 
> - -chris
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1
> Comment: GPGTools - http://gpgtools.org
> 
> iQIcBAEBCAAGBQJUYQlQAAoJEBzwKT+lPKRYJlYP/2z++JmQkCD98Egu1DMPuONj
> fnD35rCRVa2G2x9ACEJT3ItM/23jnH6LS0duoD0tnRnyWcllOC0vVHgetnLtWLlO
> FJ5A65irBTcUuBn/iO38qNbHB8Wj/Jj2c2QNpPzFTynBIB6YXJTCKn3LK5XFE7F6
> 6WeP8zKex6zDMB3SGr1UrqiLTiBxmxu7JMe2OLwDvV110pwYK7Fg9yZFz0YxyWoc
> mk6PzRffS3WAOQC3SpqyKHMYcKD3fNyrXILFZOfcDLtgz4oNVDbLhtVVP5YXiUNv
> DwgvNn5QoMCCq+JjnaUOydUhf/Asy3vTLQX+J2NAOGolpIiVffkrmv+DOPQyd1y+
> lTuNHumep/WXTCRnE1ATNgPVELkP68wtdKK2ceIdIjvtGpGB33RkUl1vSqDXWiFb
> kQ68PO2Ecij8LAW1qzizCbkx+U/nHHBX9NoaLR4WYUIFtGODeQLOUtDZoeLCMA2S
> HdCbOYcqXggmEII8yqjOj0JGwgKFu4/63oijd5PzVLEnbiu9NDlb9r7o8oTbmgdx
> 9in9jglKBTYh2a7Iy48JAQ8M1GY4cBzb4ONj3bGLT8ezJJfN9pb8wSZfstanN6bE
> 0NCnaI5hRQH0Ez6zmRV2HhGk6itqkRe8bHfQ1eo/jT7h3mcLekEAT8GVVto7jFi/
> Txsj/uIibTahKJwia0WQ
> =oZqD
> -----END PGP SIGNATURE-----
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message