tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: jespa (jcifs) does not works in Tomcat but works in single app
Date Mon, 17 Nov 2014 16:33:54 GMT
Ignacio Ocampo wrote:
> Hi all,
> 
> I've a simple *app (A)* that uses *JESPA* (and *JCIFS*), it works perfectly
> when I run this isolated. This app, has a *functionA* that call a URL with
> NTLM authentication and I use JESPA to authenticate.
> 
> I have another *app (B)* that uses *app (A)* as library with *TOMCAT*, but,
> when I call the *functionA* it doesn't work.

That is not very helpful as a problem description.  What does not work ? How do you know 
that it does not work ? What appears in the logfiles ?
What does your webapp try to do with Jespa ?

> 
> In both cases, I'm sure of:
> 
>    1. I register java protocol handler with:
> *System.setProperty("java.protocol.handler.pkgs",
>    "jespa")* at the start of the program (I tried with *JAVA_OPTS* too).
>    2. I've *jespa-1.1.20.jar* and *jcifs-1.3.18.jar* in /opt/tomcat/lib/
>    and /opt/tomcat/webapps/ROOT/WEB-INF/lib

If your purpose is only to authenticate the user of your webapp, you do not need a copy in
/opt/tomcat/lib/. That is probably a bad idea anyway.

Did you follow the steps in the Jespa manual, page 9, "Step 2: Test the Computer account 
with the Example Webapp" ?

> 
> Using CLASSPATH:
> /root/apache-tomcat-7.0.57/bin/bootstrap.jar:/root/apache-tomcat-7.0.57/bin/tomcat-juli.jar:/root/apache-tomcat-7.0.57/lib/
> *jespa.jar*:/root/apache-tomcat-7.0.57/lib/*jcifs.jar*
> 
> 

Jespa is a commercial product, not a part of Tomcat (*).
Should you not be contacting the support at www.ioplex.com / support@ioplex.com for this ?

(*) This being said, it works fine with Tomcat for me, at multiple sites and since years.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message