tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen McCants <stephen.mcca...@hcs.us.com>
Subject isELIgnored default is wrong
Date Fri, 07 Nov 2014 19:51:47 GMT
Hello All,

I'm seeing a strange problem where isELIgnored has the wrong default
value for a new Tomcat install of 5.0.56.

I'm moving a Web Application on Windows 7 to Windows 2008 and that
caused the EL expressions to stop being evaluated on the new install..  

Problem is only seen on Windows Server 2008 with Tomcat 7.0.56, while it
works correctly on Tomcat 7.0.37 (Windows 7) and 7.0.42 (Linux).  The
web application is the same on all three servers.  

Our web.xml file specifies:

<web-app
    xmlns="http://java.sun.com/xml/ns/javaee"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd" version="2.5"> 

So, I believe the correct behavior with 2.5 is that EL expressions
should be evaluated.

I worked around the problem by adding the following to
the JSP files:

<%@ page isELIgnored="false" %>

However, I'd like to understand where the configuration error is
occurring as from my perspective nothing changed except OS and Tomcat
version.  My own efforts have turned up nothing helpful or
illuminating.  

Where should I be looking in the configurations for a difference?  What
differences would come into play?

BTW, other people apparently have run into this problem:

See answer and comments on
http://stackoverflow.com/questions/793983/jsp-el-expression-is-not-evaluated .

Thanks in advance.

Sincerely,
Stephen McCants

--------
Stephen McCants
Senior Software Engineer
Healthcare Control Systems, Inc.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message