tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: tomcat8-maven-plugin
Date Sun, 12 Oct 2014 23:37:06 GMT
Hi,
I started a branch called  tc8.x ( see
https://github.com/apache/tomcat-maven-plugin )
or in svn https://svn.apache.org/repos/asf/tomcat/maven-plugin/branches/tc8.x/
The tomcat8 plugin is currently working except if you use jsp. ATM
because of low bandwith I don't have to have a look to fix that. Maybe
in the next few weeks.
But if you have time to help that will be a pleasure for me to
integrate your fix :P

Cheers
Olivier

On 11 October 2014 20:32, LG Optimusv <lgoptimusv324@gmail.com> wrote:
> Hi All,
>
> I know that there's no tomcat8-maven-plugin (yet) and using tomcat8 with
> tomcat7-maven-plugin like this:
>
> <plugin>
>     <groupId>org.apache.tomcat.maven</groupId>
>     <artifactId>tomcat7-maven-plugin</artifactId>
>     <version>2.2</version>
>     <dependencies>
>         <dependency>
>             <groupId>org.apache.tomcat.embed</groupId>
>             <artifactId>tomcat-embed-core</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-util</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-coyote</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-api</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-jdbc</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-dbcp</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-servlet-api</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-jsp-api</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-jasper</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-jasper-el</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-el-api</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-catalina</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-tribes</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-catalina-ha</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-annotations-api</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat</groupId>
>             <artifactId>tomcat-juli</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat.embed</groupId>
>             <artifactId>tomcat-embed-logging-juli</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>         <dependency>
>             <groupId>org.apache.tomcat.embed</groupId>
>             <artifactId>tomcat-embed-logging-log4j</artifactId>
>             <version>${tomcat8.version}</version>
>         </dependency>
>     </dependencies>
> </plugin>
>
> doesn't work. The error is when mvn tomcat7:run is executed is:
>
> [ERROR] Failed to execute goal
> org.apache.tomcat.maven:tomcat7-maven-plugin:2.2:run (default-cli) on
> project webapp: Execution default-cli of goal
> org.apache.tomcat.maven:tomcat7-maven-plugin:2.2:run failed: An API
> incompatibility was encountered while executing
> org.apache.tomcat.maven:tomcat7-maven-plugin:2.2:run:
> java.lang.NoSuchMethodError:
> org.apache.catalina.startup.Tomcat.setDefaultRealm(Lorg/apache/catalina/Realm;)V
>
> Is there anyway to get around this?
>
> Thanks.



-- 
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message