tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: JNDIRealm doesn't work when binding as non-admin user
Date Wed, 01 Oct 2014 12:55:09 GMT
On 01/10/2014 02:46, Jesse Barnum wrote:
> On Sep 30, 2014, at 4:06 PM, Mark Thomas <markt@apache.org> wrote:
> 
>> On 30/09/2014 20:24, Mark Thomas wrote:
>>> On 30/09/2014 15:19, Jesse Barnum wrote:
>>
>> <snip/>
>>
>>>> By the way, I've noticed that I get a NPE if I don't define roleBase with
an empty string (it should be optional, since I've specified the search base in my connectionURL).
I don't have to define userBase; it seems like the behavior should be consistent for these
two attributes.
>>>
>>> OK. I'll take a look at that NPE.
>>>
>>>> After adding the roleSearchAsUser attribute, I'm getting a new error:
>>
>> <snip/>
>>
>> OK. Both errors fixed in 8.0.x and 7.0.x for 8.0.15 and 7.0.57 respectively.
>>
>> Mark
> 
> Thank you Mark!
> 
> Is it possible to get these versions to test with, or should I wait for the download
page to be updated?

It is likely to be at least a month before those versions are released.
How do you feel about building from source? The other option is that I
can make some snapshot versions available for you to test.

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message