tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick L Archibald (PLA) ☮ <patrick.archib...@gmail.com>
Subject Websocket Ubuntu 14.04 Apache2 2.4 Tomcat 8.0.9
Date Thu, 28 Aug 2014 02:12:54 GMT
Hi,

I have a websocket app that works fine on Tomcat. I can not get it
configured to run behind Apache2 web server. Apache2 is configured
with SSL and LDAP basic authentication and uses AJP13 to talk to
Tomcat. All are running fine except for this new websocket app.

I can run this curl command.

curl --user 'SOMEUSER:SOMEPASSWORD' -i -N -H "Connection: Upgrade" -H
"Upgrade: websocket" https://SOMEDOMAIN/RealTime/chat/

It returns "HTTP/1.1 426 Upgrade Required" and I see proxy debug
messages in the error.log,  which all look good.

When I run the app on just Tomcat it works fine.

When I run the app on the Apache web server, in the Javascript console
I see: WebSocket connection to 'wss://SOMEDOMAIN/RealTime/chat'
failed: Error during WebSocket handshake: Unexpected response code:
401

I do not see any debug messages in error.log, which is not good.

I am use AJP connector. I am not using SSL between Apache and Tomcat
since they are both on the same subnet.

In my Apache virtual host config I have:

        ProxyPass /RealTime/chat/
ws://LOCALTOMCAT:8080/RealTime/chat
        ProxyPassReverse /RealTime/chat/
ws://LOCALTOMCAT:8080/RealTime/chat

I've have tried ws and wss in my ProxyPass statements. Neither work.

Question 1. Is wss required between Apache and Tomcat since I'm https
on the frontend?

Question 2. How can I tell if the version of proxy_wstunnel has been
patched from this bug?
https://issues.apache.org/bugzilla/show_bug.cgi?id=55320

Any other suggestion are welcome.

Thanks in advance, PLA

Patrick L Archibald
http://PatrickArchibald.com

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message