tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sushil Prusty <sushil.pru...@gmail.com>
Subject Problem with Transfer-Encoding
Date Sat, 05 Jul 2014 05:24:01 GMT
Hello,

summary of my Problem:

When a client POSTs Tranfer-Encoding data   using browser ,
my server is not processing the request character encoding properly .


I send the following request:
Content-Type text/html;charset=UTF-8
Date Sat, 05 Jul 2014 05:10:09 GMT
Server Apache-Coyote/1.1
Transfer-Encoding chunked
*disclaimerTextZażółć gęślą jaźń! ta funkcjonalność nie jest wspierana*

  Full details:

My application running on  apache-tomcat-7.0.40
 and Java
1.6.x)  in linux box.

Below response is changed once it's reach to my controller
*ZażóÅÄ gÄÅlÄ jaźÅ! ta funkcjonalnoÅÄ nie jest wspierana*

I have below configuration  in server.xml

 <Connector port="80" protocol="HTTP/1.1" connectionTimeout="20000"
maxPostSize="5242880" maxParameterCount="25000"/>
    <Connector
            port="443"
            protocol="HTTP/1.1"
            scheme="https"
            noCompressionUserAgents="gozilla, traviata"

compressableMimeType="text/html,text/xml,text/javascript,text/css,application/javascript,application/json"
            URIEncoding="UTF-8"
    />
and in my catalina.sh
set JAVA_OPTS=-Djavax.servlet.request.encoding=UTF-8 -Dfile.encoding=UTF-8



I suspect the problem though I'm not sure if this is a Tomcat
error or a configuration problem, or a Java-version problem.
I searched the Internet for similar problems but could only find
either ones where fixed had been introduced into Tomcat 7.x and/or
where the problem was with server _response .

Do you have any ideas what's wrong here, where the error might be ?


Thanks for your help,
Sushil

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message