tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Silent failure to deploy or run from configuration descriptor
Date Thu, 03 Jul 2014 10:27:09 GMT
2014-07-03 0:38 GMT+04:00 Gulliver Smith <gulliver.m.smith@gmail.com>:
> Apache Tomcat/7.0.28, Debian
>
> I have two configuration descriptors in /etc/tomcat7/Catalina/localhost/
>
> One, solr.xml deploys correctly and fills catalina.out with lots of
> useful messages.
>
>
> The other fails silently to start (see below).
>
> I see the message "INFO: Deploying configuration descriptor" in
> catalina.out; then there is nothing else in catalina.out.
>

1. Try with an up-to-date version of 7.0. (Such as 7.0.42 or 7.0.54).

2. If you use docBase="xxx/foo.war"  Tomcat 6 will unpack the war file
into docbase directory.

Early versions of Tomcat 7 do not unpacked the war file and run it as is.
Unpacking was reimplemented starting with 7.0.48 (BZ 51294)

Is your application able to run from an non-unpacked war?

3. "catalina.out" is not a proper log file. That is just catch of
console output.

What is in other log files (localhost.<date>.log)?

4. Scanning for annotations in a web application may take noticeable time.
http://wiki.apache.org/tomcat/HowTo/FasterStartUp

Take a thread dump and see what background thread is doing.

Do you have other symptoms of whether the application has been
deployed? Is its directory created in Tomcat's "work" directory? Is it
listed in manager webapp? Does it respond to HTTP requests?

> (...)


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message