tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Is Apache Tomcat v7/v8 compatible with Java v8
Date Wed, 14 May 2014 08:00:32 GMT
On 14/05/2014 07:44, P Manchanda wrote:
> Respected Tomcat Experts, 
>  
>  I understand this would be a commonly asked question but I was not able to reach any
concrete solution by digging
>  around the net.
>  
>  We are planning to move to Apache Tomcat (probably the latest stable version) and Java
8. So, my question is that
>  whether Apache Tomcat v7/v8 would run with Java 8 and support applications build using
Java 8. 
>  
>  The Release notes (https://tomcat.apache.org/tomcat-8.0-doc/RELEASE-NOTES.txt), mention
that Tomcat requires Java 7 or later. Similarly, a blog (https://spring.io/blog/2014/03/21/java-8-in-enterprise-projects)
also claims (and explains why) Tomcat's compatibility. 
>  
>  However, a discussion on SO (http://stackoverflow.com/questions/18208805/does-tomcat-8-support-java-8),
>  has claims and counter claims regarding this. 
>  
>  So, hoping to get a concrete confirmation -- either ways -- from this group.

http://tomcat.apache.org/whichversion.html

Mark


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message