tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Exception while running downloaded tomcat
Date Fri, 14 Mar 2014 11:59:36 GMT
2014-03-14 12:11 GMT+04:00 Akash Jain <akash.delhite@gmail.com>:
> I am getting following error when trying to run tomcat in Mac osx 10.7.5 (
> using jdk 1.7 )
>
> Can anybody please guide as to what is wrong ?
>
> r 14, 2014 12:04:59 AM org.apache.catalina.startup.HostConfig
> deployDirectory
> INFO: Deploying web application directory
> /Users/myuser/Downloads/apache-tomcat-7.0.52 2/webapps/docs
> Mar 14, 2014 12:04:59 AM org.apache.catalina.startup.HostConfig
> deployDirectory
> SEVERE: Error deploying web application directory
> /Users/myuser/Downloads/apache-tomcat-7.0.52 2/webapps/docs
> java.lang.ExceptionInInitializerError
>...
> Caused by: java.lang.NullPointerException
> at
> org.apache.tomcat.util.descriptor.DigesterFactory.idFor(DigesterFactory.java:107)
> at
> org.apache.tomcat.util.descriptor.DigesterFactory.<clinit>(DigesterFactory.java:59)
> ... 18 more
>


Fix your configuration.
You have a wrong rogue servlet-api.jar somewhere in your classpath,
See
https://issues.apache.org/bugzilla/show_bug.cgi?id=56236

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message