tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From javier_esp...@hna.honda.com
Subject RE: unable to start Tomcat through the Windows Services panel
Date Thu, 06 Feb 2014 18:13:32 GMT
Andre:
I used the batch file "SERVICE.BAT INSTALL"  without any additional
parameters.  Was I missing some parameter? Or is there a better way of
installing Tomcat?

Thank you

Javier España
Sr. Technical Analyst
Honda North American Services, LLC.
Information Services Division
ISD Applications
1919 Torrance Blvd.,
Torrance, CA 90501
(310) 781-4514
Email: javier_espana@hna.honda.com
www.honda.com

***Beginning April 1, 2013 my email changed to javier_espana@hna.honda.com.
Please update your contact information.
Thank you.***





From:	Jeffrey Janner <Jeffrey.Janner@PolyDyne.com>
To:	"'Tomcat Users List'" <users@tomcat.apache.org>, "'Tomcat Users
            List'" <users@tomcat.apache.org>,
Date:	02/06/2014 08:43 AM
Subject:	RE: unable to start Tomcat through the Windows Services panel



> -----Original Message-----
> From: André Warnier [mailto:aw@ice-sa.com]
> Sent: Thursday, February 06, 2014 10:33 AM
> To: Tomcat Users List
> Subject: Re: unable to start Tomcat through the Windows Services panel
>
> Hi.
>
> javier_espana@hna.honda.com wrote:
> > OK, this is what I see in the Event Viewer under General tab "The
> > tomcat7 service terminated with service-specific error Incorrect
> > function.."
> >
>
> Let's start from the beginning.
>
> If you don't get logfiles in the Tomcat/logs directory, then chances
> are that Windows does not even begin to run Tomcat, and that there is
> an error right at the start, when it tries to run it.
>
> So first read this : http://wiki.apache.org/tomcat/FAQ/Windows#Q11
>
> That will explain /what/ you are actually running, when you (try to)
> run Tomcat as a Service in Windows, and why it is different from
> running Tomcat in a command window.
> Go ahead, read it, we'll wait right here.
>
> ... some time later :
>
> Now you know
> - that tomcat7.exe is a Windows executable program
> - it is the program which the Windows Service Manager tries to start,
> when you start the
> Tomcat7 Service
> - but tomcat7.exe is not really Tomcat; it is a "wrapper" program that
> runs the Java JVM which in turn runs Tomcat.
>
> And to start the Java JVM, and pass to this java JVM the appropriate
> parameters, tomcat7.exe reads these parameters from the Windows
> Registry somewhere.
>
> And to be nice, the Tomcat developers have even provided a specialised
> GUI editor, that allows you to view, set or modify these Tomcat
> Registry parameters that are used by tomcat7.exe.
> And that is the program tomcat7w.exe.  So go ahead now, double-click on
> tomcat7w.exe, and look at the information it shows in the various tabs.
> That is probably where something is wrong.
>
> Or else what is wrong, is that the version of tomcat7.exe that you have
> installed, does not match the version of Windows that you are running.
> For example, tomcat7.exe is a 32-bit program, but your Windows PC runs
> a 64-bit version of Windows.  Or vice-versa.
>
> Or that in the Service definition of the Tomcat7 Service, the path to
> tomcat7.exe is incorrect.
> You see that path in the first tab of the GUI.
>

André -
Good points. I'd been following this thread out of curiosity and was just
beginning to think that it was obviously a service configuration error.  I
don't have the entire thread handy, and haven't looked at MarkMail, but I
don't remember anyone asking the OP exactly *how* he installed the service.
One would assume he used the bat file that is designed to do this, since he
mentions running tomcat from the console using startup.bat (a clear
giveaway that he's not using the fine Windows installer package that
someone spent a lot of time crafting).
Personally, I only use the installer, and never run into startup problems
unless I've set some optional parameter to an invalid value, e.g. setting a
heap size > than 1.5GB on a 32-bit machine, etc.
As you said, if you're not seeing any log files generated, then the java
isn't even getting started, so it could be several factors, not the least
of which is an invalid path to the JVM or the Tomcat jar files, etc.
Jeff


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message