tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Kennedy <davek1...@gmail.com>
Subject Re: Eclipse: Server Tomcat v7.0 Server at localhost failed to start.
Date Tue, 18 Feb 2014 00:16:28 GMT
Hi Martin,
Even though $CATALINA_HOME/lib is on the project Java Build Path
I needed to add
  servlet-api.jar
  jsp-api.jar
  el-api.jar
to the 'Eclipse Tomcat Server' Launch Configuration | Classpath | Bootstrap
Entries
to run the app

Dave


On Sat, Feb 15, 2014 at 5:45 PM, Martin Gainty <mgainty@hotmail.com> wrote:

>
>
>
> > Date: Fri, 14 Feb 2014 14:19:04 -0800
> > Subject: Re: Eclipse: Server Tomcat v7.0 Server at localhost failed to
> start.
> > From: davek1802@gmail.com
> > To: users@tomcat.apache.org
> >
> > OK I added servlet-api.jar and jsp-api.jar to the
> > Launch Configuration | Classpath | Bootstrap Entries
> >
> > and get the following error report:
> > HTTP Status 500 - java.lang.NoClassDefFoundError: javax/el/ELResolver
> >
> >
> > HTTP Status 500 - java.lang.NoClassDefFoundError: javax/el/ELResolver
>
> MG>Dave
> MG>can you confirm el-api.jar is located in lib folder of $CATALINA_HOME ?
> MG>$CATALINA_HOME/lib/el-api.jar
> MG>Martin-
> > ------------------------------>
> >
> > *note* *The full stack trace of the root cause is available in the Apache
> > Tomcat/7.0.50 logs.*
> > ------------------------------
> > Apache Tomcat/7.0.50
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message