tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Tomcat 7.0.50 on IBM i series - System i V7R1 - Installation errors
Date Sun, 02 Feb 2014 16:23:43 GMT
2014-02-01 Jakati, Shekar <Shekar.Jakati@lfg.com>:
> Hello friends,
>
>    We are new to using Tomcat. Installed Apache Tomcat on our development box and runs
great.
>
> Tried to install Apache 7.0.50 on our production box with similar configuration i.e.
'IBM Series System I running V7R1 'and get the below error.  Part of the "catalina.2014-01-31"
log file is attached.
> Unable to figure out what is causing this problem. Any help or pointers is much appreciated.
> *******
> Jan 31, 2014 9:55:56 AM org.apache.catalina.core.AprLifecycleListener init
> Jan 31, 2014 10:02:26 AM org.apache.coyote.AbstractProtocol pause
> INFO: Pausing ProtocolHandler ["http-bio-8080"]
> Jan 31, 2014 10:02:27 AM org.apache.coyote.AbstractProtocol pause
> INFO: Pausing ProtocolHandler ["ajp-bio-8009"]
> Jan 31, 2014 10:02:27 AM org.apache.catalina.core.StandardService stopInternal
> INFO: Stopping service Catalina
> Jan 31, 2014 10:02:27 AM org.apache.coyote.AbstractProtocol stop
> INFO: Stopping ProtocolHandler ["http-bio-8080"]
> Jan 31, 2014 10:02:27 AM org.apache.coyote.AbstractProtocol stop
> INFO: Stopping ProtocolHandler ["ajp-bio-8009"]
> Jan 31, 2014 10:02:28 AM org.apache.coyote.AbstractProtocol destroy
> INFO: Destroying ProtocolHandler ["http-bio-8080"]
> Jan 31, 2014 10:02:28 AM org.apache.coyote.AbstractProtocol destroy
> INFO: Destroying ProtocolHandler ["ajp-bio-8009"]
> Jan 31, 2014 10:03:05 AM org.apache.catalina.core.AprLifecycleListener init
> INFO: The APR based Apache Tomcat Native library which allows optimal performance in
production environments was not found on the java.library.path: /QSYS.LIB/NQSYS.LIB:/QSYS.LIB:/QSYS.LIB/QSYS2.LIB:/QSYS.LIB/QHLPSYS.LIB:/QSYS.LIB/QUSRSYS.LIB:/QSYS.LIB/RBTSYSLIB.LIB:/QSYS.LIB/QSHELL.LIB:/QSYS.LIB/TOMCAT.LIB:/QSYS.LIB/QTEMP.LIB:/QOpenSys/QIBM/ProdData/JavaVM/jdk70/32bit/jre/lib/ppc:/QOpenSys/QIBM/ProdData/JavaVM/jdk70/32bit/jre/lib/ppc/classic:/QOpenSys/QIBM/ProdData/JavaVM/jdk70/32bit/jre/lib/ppc/default:/QOpenSys/QIBM/ProdData/JavaVM/jdk70/32bit/jre/bin:/QOpenSys/QIBM/ProdData/JavaVM/jdk70/32bit/jre/bin/classic
> Jan 31, 2014 10:03:06 AM org.apache.coyote.AbstractProtocol init
> INFO: Initializing ProtocolHandler ["http-bio-8080"]
> Jan 31, 2014 10:03:07 AM org.apache.coyote.AbstractProtocol init
> INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
> Jan 31, 2014 10:03:07 AM org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 2377 ms
> Jan 31, 2014 10:03:07 AM org.apache.catalina.users.MemoryUserDatabase open
> WARNING: Exception configuring digester to permit java encoding names in XML files. Only
IANA encoding names will be supported.
> org.xml.sax.SAXNotRecognizedException: http://apache.org/xml/features/allow-java-encodings
>                 at gnu.xml.aelfred2.JAXPFactory.setFeature(JAXPFactory.java:102)

"gnu.xml" package?!

What JVM and XML parser are you using?

> Jan 31, 2014 10:03:07 AM org.apache.catalina.core.StandardService startInternal
> INFO: Starting service Catalina
> Jan 31, 2014 10:03:07 AM org.apache.catalina.core.StandardEngine startInternal
> INFO: Starting Servlet Engine: Apache Tomcat/7.0.50
> Jan 31, 2014 10:03:07 AM org.apache.catalina.startup.HostConfig deployDirectory
> INFO: Deploying web application directory /Tomcat/apache-tomcat-7.0.50/webapps/ROOT
> Jan 31, 2014 10:03:07 AM org.apache.catalina.startup.HostConfig deployDirectory
> SEVERE: Error deploying web application directory /Tomcat/apache-tomcat-7.0.50/webapps/ROOT
>(...)
> Caused by: java.lang.NullPointerException
>                 at org.apache.tomcat.util.descriptor.DigesterFactory.idFor(DigesterFactory.java:107)
>                 at org.apache.tomcat.util.descriptor.DigesterFactory.<clinit>(DigesterFactory.java:53)
>                 at java.lang.J9VMInternals.initializeImpl(Native Method)
>                 at java.lang.J9VMInternals.initialize(J9VMInternals.java:237)
>                 ... 18 more

The above in 7.0.50 is usually caused by missing jsp-api.jar.

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message