tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Singh, Ragini" <rsi...@Central.UH.EDU>
Subject RE: Tomcat 7 / Java 7
Date Tue, 04 Feb 2014 15:05:15 GMT
Thank you Christopher!! I understand that the message is just an INFO and not an error. Also,
I haven’t installed tcnative as I am not using it. My question was regarding the difference
in messages when I change JAVA version using JAVA_HOME. Is there a way I can find out which
version of JAVA Tomcat is using?

Thank you,
-Ragini

-----Original Message-----
From: Christopher Schultz [mailto:chris@christopherschultz.net] 
Sent: Monday, February 03, 2014 3:42 PM
To: Tomcat Users List
Subject: Re: Tomcat 7 / Java 7

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Ragini,

On 2/3/14, 4:19 PM, Singh, Ragini wrote:
> I upgraded Java 1.6.45 to Java 1.7.51 using
> java-1.7.0-oracle.x86_64 : Oracle Java Runtime Environment on RHEL 5. 
> Used the "alternatives" command to make the Java 7 as Java version. 
> Now in my custom startup script if I define JAVA_HOME as 
> JAVA_HOME="/usr/lib/jvm/java" tomcat 7 recognizes the java as 1.6 ( 
> the previous version) and gives this message "INFO: The APR based 
> Apache Tomcat Native library which allows optimal performance in 
> production environments was not found on the java.library.path:
> /usr/lib/jvm/java-1.6.0-sun-1.6.0.45
> .x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-sun-1.6.0.45.x86_
> 64/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-sun-1.6.0.45.x86_64/jre/../li
> b/amd64:/usr/java/packages/lib/amd64:/usr/lib
>
> 
64:/lib64:/lib:/usr/lib"
> 
> I modified the JAVA_HOME to
> JAVA_HOME="/usr/lib/jvm/jre-1.7.0-oracle.x86_64". Now tomcat starts 
> and gives the message as "INFO: The APR based Apache Tomcat Native 
> library which allows optimal performance in production environments 
> was not found on the java.library.path:
> /usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib"
> 
> I believe it is not recognizing the correct Java version which is 1.7. 
> Am I missing anything ?

Have you installed tcnative? Installing tcnative is a prerequisite for using tcnative.

Note that the above is an INFO message and not an error in any way.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJS8A0eAAoJEBzwKT+lPKRYss8P/05QCOEVNmHlbjrvyZplv2yI
vLb9GL+5YhzNMawHoAKOeGzs3Pjkoux0+zbV5MNrvOZKhoM9r299eaoJTD9LVNbw
Udz/Ip9TYmdPmP5OczO8D9+FNQX2pfzqSVMABMlLvi0/scC3EyV7/+PAZUEc/lYv
K1Xm4mXiQpxCBBeS1v7D27WLzQGuIj4hj76aEwSf1tsw0GwMT6YKGioCjtSdBSeQ
hVRmVI4CcqYwVrCNDXEF9El1ZO4QDN0l4FouApJd7/mlwTT6qRE9uTP9RUFmCGKh
GT7yvP+rTnJ95A+c1jUe+FNRQDbiBAK+WMmqeNUL0GF/NVbGsL/DNykt1wrT1kR/
XgMsPWS/jFCeqpEpBBucKTrJalhNFiFltI1BLa0Lpc7eKtkWHbaDhFiSff/Q+Vf5
/ONLXsCmOSdDbzub7YH8CLlfWdykLJH++MuH1LPzy3dEkiCSFtwdAcmCo1fykH38
EtT0+Go0LNWoMKSQZYPOT3O5b71e3UgoKw8p9NWRpLNtsIVRFFsZZMomgBiVldQ1
H26Ng6rIK2XP+Aieq5V2VdraAByPkGQcKjGUexykPKZ4fewuCmKpQ+gKplxDyxFx
uP/VcRp0jywUv/4kHjMBZG+eOFPySZ09i6QkZB80cIcoRIcfseTiBh0LqchclKyA
VVbHk5QH86nuIKTo9zYF
=JVDD
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org

Mime
View raw message