tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Borland <jborl...@calpoly.edu>
Subject Re: mod-jk stopped working
Date Sat, 15 Feb 2014 06:22:27 GMT
Wow!  I put my JkMounts inside the VirtualHost directives and now it is working again.  Thank
you very much!

On Feb 14, 2014, at 11:52 AM, Christopher Schultz <chris@christopherschultz.net> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
> 
> Jim,
> 
> On 2/12/14, 11:53 PM, Jim Borland wrote:
>> Apache 2.2 and Tomcat 6 on Linux Ubuntu 10.10
>> 
>> My connector worked fine for several years and then suddenly
>> stopped working!  Now I get a "requested URL was not found on this
>> server" error instead.
> 
> This sounds like a missing JkMount in httpd or even a non-deployed
> webapp in Tomcat. Can you tell which component it generating the page
> (httpd versus Tomcat)?
> 
> I've tried several things to fix this but no joy. Here is the
>> current content of my two files:
>> 
>> ==============================
>> 
>> workers.properties file -->
>> 
>> workers.tomcat_home=/usr/share/tomcat6 
>> workers.java_home=/usr/lib/jvm/java-6-openjdk/jre ps=/ 
>> worker.list=ajp13_worker worker.ajp13_worker.port=8009 
>> worker.ajp13_worker.host=localhost worker.ajp13_worker.type=ajp13 
>> worker.ajp13_worker.lbfactor=1 worker.loadbalancer.type=lb 
>> worker.loadbalancer.balance_workers=ajp13_worker
>> 
>> ==============================
>> 
>> httpd.conf file -- >
>> 
>> LoadModule jk_module /usr/lib/apache2/modules/mod_jk.so 
>> JkWorkersFile   /etc/libapache2-mod-jk/workers.properties JkShmFile
>> /var/log/apache2/mod_jk.shM JkLogFile
>> /var/log/apache2/mod_jk.log JkLogLevel      info JkLogStampFormat
>> "[%a %b %d %H:%M:%S %Y] "
>> 
>> JkMount /big41       ajp13_worker JkMount /big41/*
>> ajp13_worker JkMount /big50       ajp13_worker JkMount /big50/*
>> ajp13_worker
>> 
>> JkMount /*.jsp ajp13_worker JkMount /*/servlet/ ajp13_worker
>> 
>> ==============================
> 
> Did you declare these JkMounts in a VirtualHost? Did you define them
> at the top-level and then try to use them in a virtual host? If you do
> a JkWorkersFile and JkMount at the top-level, they won't work within
> virtual hosts. You have to either explicitly-add them to all virtual
> hosts, or use JkMountCopy in each virtual host that should inherit the
> configuration.
> 
> Maybe you added a new virtual host and forgot JkMountCopy? Or switched
> from non-virtualhost configuration to one with a "default" virtual
> host instead of none at all?
> 
> - -chris
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1
> Comment: GPGTools - http://gpgtools.org
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
> 
> iQIcBAEBCAAGBQJS/nPzAAoJEBzwKT+lPKRYK+IP/2beJ98jzAJNW10fHNHU8poR
> sVze1TZr53hVjSGiS76xV8eoPO164egmrv9DVDKqWmk/0sWYyjmutUTLCXUXIwOA
> kNw0g0LF6xHQhBL/Mle8IXlSokwlBOvkuu02ILf25N4CGAr9yap0uGNFb2RsWLvR
> AmZWseNU6ALmLgaiMStpxXMwnjR4OHIiaxrJUm1QFKlo7AIIWodql3lUibUzuK2y
> uIl4yxcd5JnQWozEaT6qh4y/8nk2EEvvJAxxfSvDZWtL1u0UTK1YsZ0SpOA1milL
> LjFoRzVMX1pGtrik2XsEAt2lkna7TWNMi5qCIlRqSrX27z/QJBqsCgByk4wtpecp
> BBo6scXHbi8ksyFud338GB5OIgWHE+nOXNGcUS24CvETcDlnKJhZ4PyeIH/RsyRM
> vX7u/Y2q5EytwczyK8Ai+mDMMTrygBLNm1TbU43wNG6R473YtIsbRiwAMxJLI2W8
> AyhHW95/KioUqQt8kUZgNRiQukGYNUqz4Lj4+fvuuHKW4TUQ8/zNnjW5agOFiEcB
> /G6dskV9Os4sFLq+SqUaYl725eXqcIGoowsH7cfW32J4sZv1eCcnzXgR+AgBVg+b
> zMioWdNAI2q/5g9XZ1/wjKtacae1wH7IQLyXKfdY0l+PEwf9hAsYQ3ZRIbKq8aGb
> Ax6Diqn/lFLWBe3xkTFP
> =rZAN
> -----END PGP SIGNATURE-----
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message