tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Issue running Websockets JSR356 with Tomcat 7.0.50 Embedded
Date Wed, 29 Jan 2014 15:50:23 GMT
On 29/01/2014 15:42, Jacopo Cappellato wrote:
> Hello all,
> 
> I am trying to deploy and use Websockets using the Tomcat 7.0.50 *Embedded* distribution
[*].

Java version?

> Some more details on my environment:
> * I have the following jars in my classpath:
> ** tomcat-7.0.50-tomcat-embed-core.jar
> ** tomcat-7.0.50-tomcat-embed-jasper.jar
> ** tomcat-7.0.50-tomcat-embed-logging-log4j.jar
> ** tomcat-7.0.50-tomcat7-websocket.jar
> ** tomcat-7.0.50-websocket-api.jar
> ** ecj-4.2.2.jar
> ** annotations-api-3.0.jar
> ** jsp-api-2.2.jar
> ** servlet-api-3.0.jar
> * I have mounted the "examples" webapp that comes with Tomcat (Core distribution) using
the Embedded Tomcat instance: all the examples work fine (including the websocket-deprecated
ones) except for the Websockets JSR356 ones

I think you may have duplicated some classes there. Some of those API
JARs may not be required.

> When I try to run the Websockets JSR356 examples, when I try to "Connect" (either using
the programmatic API or the annotation API) I get the message: 
> Info: WebSocket connection closed.
> Nothing appears in the console.

The HTTP headers send and received would help you to debug / enable us
to provide you with some pointers.

Mark


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message