tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James H. H. Lampert" <jam...@touchtonecorp.com>
Subject Re: On one particular box, Tomcat 7.0.25 runs just fine, but 7.0.47 crashes on takeoff -- some authority problem
Date Mon, 09 Dec 2013 23:06:08 GMT
On 12/9/13 2:51 PM, Christopher Schultz wrote:
> Can you confirm that qsh is telling you it can't actually run
> /foo/tomcat/bin/startup.sh because of a permissions problem, or is it
> that /foo/tomcat/bin/startup.sh *is* running and something it's trying
> to do is failing?
>
> Does it fail when running from the command-line, or from some
> scheduled job, startup script, etc.?

As I recall from Friday, I got the same error message whether I ran it 
from my STRTOMCAT CL program (which, among other things, finds and 
selects the best available JVM on the box, and sets up environment 
variables to avoid the need to set them in catalina.sh or the preferred 
setenv.sh, before submitting it as a batch job), or from a QShell 
command line (which is not an especially useful way to run it, given 
that it would come crashing down around its knees as soon as I exit QShell).

But that doesn't tell me anything, one way or the other. And neither 
does the audit journal entry for the authority problem (it might tell 
somebody else what was going wrong, but not me).

And yet, as I just posted, changing the owner of the entire subtree, 
something that one would expect (especially given the user profile under 
which I'm signed on) to either have no effect at all, or to break a 
working Tomcat, caused it to start working as if nothing had ever been 
wrong. Which leaves me more puzzled than ever.

--
JHHL


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message