tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Mikusa <dmik...@gopivotal.com>
Subject Re: %F in AccessLogValve
Date Thu, 05 Dec 2013 15:58:02 GMT
On Dec 5, 2013, at 10:55 AM, Daniel Mikusa <dmikusa@gopivotal.com> wrote:

> On Dec 5, 2013, at 10:31 AM, francisco.sanmartin-gomez@here.com wrote:
> 
>> Hello,
>> 
>> I'm trying to use the %F in the AccessLogValve but all I'm getting in the logs is
the string: "???F???"
> 
> Seems like this option is not available in your version.  

You need 7.0.42 or greater.

https://issues.apache.org/bugzilla/show_bug.cgi?id=55102

> Have you tried the latest release?
> 
> Dan
> 
>> 
>> This is the configuration in server.xml
>> 
>> <Host name="localhost"  appBase="webapps"
>>           unpackWARs="true" autoDeploy="true">
>>       <Valve className="org.apache.catalina.valves.AccessLogValve" directory="logs"
>>              prefix="localhost_access_log." suffix=".txt"
>>              pattern="%h %l %u %t &quot;%r&quot; %s %b ttp: %D ttc: %F" />
>> 
>>     </Host>
>> 
>> And I'm using
>> Name        : tomcat7
>> Arch        : noarch
>> Version     : 7.0.39
>> 
>> 
>> Any ideas?
>> 
>> Thanks in advance.
>> 
>> Kind regards,
>> 
>> Francisco "Pako" Sanmartin
>> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message