tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Albert Kam <moonblade.w...@gmail.com>
Subject How to force undeployOldVersions ?
Date Sat, 02 Nov 2013 14:42:16 GMT
I have had a good experience doing the parallel deployment with the latest
stable build of tomcat7, by using autoDeploy after copying a newer version
of WAR to the appbase. As i can see from my manager app, there are 2
versions running, the newer one is serving new requests as expected.

The problem is that, although with undeployOldVersions=true, the old
version of the webapp is still there.
>From what i've seen from catalina.out, there's a ThreadLocal issues that
are being used by 3rd party classes and i assumes this is the output of the
undeployment process failing.

Is there a way that i can 'force' the undeployOldVersions ?
I've thought about using ant task to undeploy, but it seems that i cannot
specify the version to undeploy.

-- 
Do not pursue the past. Do not lose yourself in the future.
The past no longer is. The future has not yet come.
Looking deeply at life as it is in the very here and now,
the practitioner dwells in stability and freedom.
(Thich Nhat Hanh)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message