tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: How to force undeployOldVersions ?
Date Sat, 02 Nov 2013 16:50:12 GMT
2013/11/2 Albert Kam <moonblade.wolf@gmail.com>:
> Hello. I forgot to mention that i've made sure from manager app that the
> old webapp has 0 sessions, so i think this should have triggered the
> undeploying process.
>
> Here's my host's attributes :
> <Host name="localhost"  appBase="webapps"
>             unpackWARs="true" autoDeploy="true" undeployOldVersions="true">
>
> And i've just done some greps on catalina.out, and i got this related
> output :
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property
> 'undeployOldVersions' to 'true' did not find a matching property.
>
> I've seen that in the onfig it's indeed undeployOldVersions, and the value
> of true is also fine.
> I wonder what might be the cause of the warning.
>
> I'm using debian wheezy's tomcat7 packages.
>

3-rd party packages are usually rather old. Looking at that error
message it seems that yours does not have this feature.

What x.y.z version of Tomcat is that?

You need Tomcat 7.0.32 or later.
http://tomcat.apache.org/oldnews-2012.html#Tomcat_7.0.32_Released

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message