tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey Janner <Jeffrey.Jan...@PolyDyne.com>
Subject RE: [OT] RE: Baked-in context paths
Date Wed, 13 Nov 2013 16:13:33 GMT
> -----Original Message-----
> From: Konstantin Preißer [mailto:kpreisser@apache.org]
> Sent: Wednesday, November 13, 2013 7:17 AM
> To: 'Tomcat Users List'
> Subject: RE: [OT] RE: Baked-in context paths
> 
> > -----Original Message-----
> > From: Konstantin Preißer [mailto:kpreisser@apache.org]
> > Sent: Tuesday, November 12, 2013 8:09 PM
> > To: 'Tomcat Users List'
> > Subject: RE: [OT] RE: Baked-in context paths
> >
> > Hi Jeffrey,
> >
> > > -----Original Message-----
> > > From: Jeffrey Janner [mailto:Jeffrey.Janner@PolyDyne.com]
> > > Sent: Tuesday, November 12, 2013 4:22 PM
> > > To: 'Tomcat Users List'
> > > Subject: RE: [OT] RE: Baked-in context paths
> > >
> >
> > I'm also using Outlook, but for me it only shows an empty email here.
> >
> > If I open the mail in the Apache Mail-Archives (http://mail-
> > archives.apache.org/mod_mbox/tomcat-
> > users/201311.mbox/%3C7215BA462D00D343B2837F9113F0131F0181A0E612%
> > 40POSTOFFICE02.polydyne.com%3E), then I can see the text, but it does
> > not show the three "To unsubscribe ..." text added by the list mailer
> > at the bottom.
> >
> > If I view the raw message, I can see two Base64 encoded blocks. The
> > first block contains the email text, the second one contains the
> three
> > lines added by the mailer.
> >
> > I would guess that your Outlook tries to decode the two blocks as one
> > block (which fails), so latter produces the junk which you can see
> > (and probably because of this I get an empty mail).
> >
> > However, I don't have much knowledge about email standards or Outlook
> > to know what exactly is wrong here.
> 
> BTW,
> 
> If I take the two Base64 blocks of your message, remove the first "="
> sign from the end of the first block, remove all whitespaces and decode
> it as one block, then I get the same "junk" characters end the end of
> the message text.
> I also opened the mail in another mail client (some web mail UI from my
> mailbox provider) and it also shows the message text with some junk
> characters at the end.
> 
> My guess would be that the problem here is not Outlook (however one
> could question why it is encoding the sent message content as Base64 in
> the first place, instead of something like quoted-printable), but the
> list mailer, as instead of just adding another Base64 block which
> produces invalid data, it probably should decode the first block, add
> the "To unsubscribe..." text, and re-encode it, so that it is one valid
> Base64 block.
> 
> However, because in this case the message content is invalid Base64, it
> depends on the client how it tries to work-around it (so in my case, it
> shows only an empty message).
> 
> 
> Regards,
> Konstantin Preißer
> 

The thing is, the garbage characters at the end don't exist in the email I see as I type.
They are either hidden in the editor or getting added by Outlook (2007) or Exchange (2010).
Mime
View raw message