tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Bad Gateway
Date Wed, 09 Oct 2013 08:20:51 GMT
On 09/10/2013 04:43, Salisbury, Richard W DLA CTR TRANSACTION SERVICES

<snip/>
> We confirmed that Tomcat on server-B is configured to handle port 53309,
> from this excerpt from its server.xml:
> <Connector description="Content Switch HTTPS" maxHttpHeaderSize="8192"
> maxThreads="150" 
> minSpareThreads="25" maxSpareThreads="75" enableLookups="false"
> disableUploadTimeout="true" 
> acceptCount="100" scheme="https" secure="true"
> keystoreFile="/keystore/server-ks.p12" 
> keystoreType="PKCS12" keystorePass="pass"
> truststoreFile="/keystore/ts.jks" truststoreType="JKS" 
> truststorePass="pass" clientAuth="false" algorithm="SunX509"
> sslProtocol="TLS" port="53309" />
>  
> We confirmed Tomcat was started successfully on server-B and listening
> on port 53309, from the application log:
> 2013-08-22 18:01:49,321 INFO : Succesfully started Apache Tomcat/6.0.35
> @ Catalina:53309
>  
> Any ideas on what might be going on?

You appear to be missing SSLEnabled="true" on your Tomcat connector.

The start-up log messages for that connector will confirm whether that
analysis is correct.

Mark


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message