tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Issue while using SSL with Embedded Tomcat 6.0.37
Date Tue, 08 Oct 2013 12:38:25 GMT
Chirag Dewan wrote:
> Hi All,
> 
> I am using Embedded Tomcat 6.0.37. I have a servlet which is running over HTTPS using
SSL Connector. I have a Java Keystore with Customer Certificate imported in it.
> 

I cannot answer your question, but I think that in order to be helped faster, it would be

a good idea to paste here your Tomcat SSL <Connector> configuration :

...


> Now,there is a HTTP Client on the customers end which connects with the servlet over
HTTPS(I have very little information about the customers client configuration)
> 
> The problem we are facing is:
> 
> For the first request from Client,the SSL handshaking fails. From second request,handshaking
is completed successfully and the requests are processed. I have observed when Server selects
 TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA  as the cypher suite,only then the Server sends a reset
to the client and the handshaking fails. On second request,with same cypher suite,it works
fine.
> 
> Can anyone assist me in understanding why it is failing for the first time? And is there
any way I can force the Tomcat not to select this cypher suite? Or any other way that I can
resolve this issue.
> 
> Thanks a lot.
> 
> Chirag Dewan
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message