tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Scarborough <adam.scarboro...@mmodal.com>
Subject FW: Tomcat 7.0.40 on Win2k8 occasionally does not deploy war file on restart
Date Wed, 04 Sep 2013 14:38:47 GMT
Hi

I was wondering if anyone can help

We have an issue with with tomcat7 deploying wars on server2k8 which is quite perplexing:

Essentially the normal and desired procedure is that we build a new set of wars (using jenkins)
which are then moved to an output directory, this change in the output directory is detected
by puppet, which then overwrites the war file in the tomcat webapps folder and restarts the
tomcat7 service (we have hot deployment disabled and deployonstartup enabled) On startup tomcat
unpacks the war files to the folder inside the webapps directory. This happens 95% of the
time.

However

We noticed an issue occasionally that the new version of the webapp would not be deployed
after starting tomcat. At this point we noticed some access denied errors (sometimes) when
the deployment failed. At this point we thought this may be due to windows file locking behaviour,
At this point we enabled antiResourceLocking in the hopes that these would go away - They
did however we still have a seemingly separate issue where webapps deploy into the temp folder,
and the log reports successful deployment with no errors. However the version in the webapps
folder is not updated and the previous version of the webapp is brought up by tomcat. We have
been unable to locate anything in the logs which might tell us what is going on.

Any help would be appreciated

Adam


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message