tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob DeRemer <bob.dere...@thingworx.com>
Subject any known problems using Tomcat 7.0.42 apr/native (windows) with websockets?
Date Tue, 06 Aug 2013 01:45:16 GMT
QUESTION
Is anyone aware of any problems using the apr/native connector + websockets in Tomcat 7.0.42?

BACKGROUND
We are trying to see how many concurrent websocket connections Tomcat will handle running
on Windows Server.   We wrote a multi-threaded java console app that spins up a thread-per
simulated websocket client.  In each thread, we are using a separate Ning websocket client.
 Unfortunately, we can't connect more than a few connections before we start getting websocket
errors.

If we change the connector to use NIO, the sporadic connection errors seem to go away, but
then we find that after about 200 connections, the communication seems to hang.  This happens
if all connections are made from a single test client instance or spread across multiple client
instances.

We're trying to determine where the problem lies and if it's in our use of Ning in a multi-threaded
client app, Tomcat connector configuration, use of Tomcat websockets on Windows or something
else.

If anyone has any suggestions, I would greatly appreciate it.  If you need additional information,
please don't hesitate to ask.

Thanks,

Bob DeRemer
Senior Director, Architecture and Development

[Description: Description: Description: Description: cid:image001.png@01CBE3DE.51A12030]
http://www.thingworx.com<http://www.thingworx.com/>
Skype: bob.deremer.thingworx
O: 610.594.6200 x812
M: 717.881.3986


Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message