tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Edison <justdoit.thomas.edi...@gmail.com>
Subject java.lang.NoClassDefFoundError
Date Wed, 10 Jul 2013 01:40:50 GMT
Hello all,

*Summary*
I'm trying to install Hadoop webhdfs from Cloudera CDH4.  This tool relies
on Tomcat to work.  The installation process seems to be fine and the
process can actually start.  However the program seems not to be running
correctly - I tried to access the service through a curl call, but it tells
me cannot connect to the server.

*This is what I see when I start the webhdfs service:*
Setting HTTPFS_HOME:          /usr/lib/hadoop-httpfs
Using   HTTPFS_CONFIG:        /etc/hadoop-httpfs/conf
Sourcing:                    /etc/hadoop-httpfs/conf/httpfs-env.sh
Using   HTTPFS_LOG:           /var/log/hadoop-httpfs/
Using   HTTPFS_TEMP:           /var/run/hadoop-httpfs
Setting HTTPFS_HTTP_PORT:     14000
Setting HTTPFS_ADMIN_PORT:     14001
Setting HTTPFS_HTTP_HOSTNAME: ip-10-29-8-55.ec2.internal
Using   CATALINA_BASE:       /usr/lib/hadoop-httpfs
Using   HTTPFS_CATALINA_HOME:       /usr/lib/bigtop-tomcat
Setting CATALINA_OUT:        /var/log/hadoop-httpfs//httpfs-catalina.out
Using   CATALINA_PID:        /var/run/hadoop-httpfs/hadoop-httpfs-httpfs.pid

Using   CATALINA_OPTS:
Adding to CATALINA_OPTS:     -Dhttpfs.home.dir=/usr/lib/hadoop-httpfs
-Dhttpfs.config.dir=/etc/hadoop-httpfs/conf
-Dhttpfs.log.dir=/var/log/hadoop-httpfs/
-Dhttpfs.temp.dir=/var/run/hadoop-httpfs -Dhttpfs.admin.port=14001
-Dhttpfs.http.port=14000 -Dhttpfs.http.hostname=ip-10-29-8-55.ec2.internal
Using CATALINA_BASE:   /usr/lib/hadoop-httpfs
Using CATALINA_HOME:   /usr/share/tomcat7
Using CATALINA_TMPDIR: /var/run/hadoop-httpfs
Using JRE_HOME:        /usr/java/jdk1.6.0_43
Using CLASSPATH:       /usr/share/tomcat7/bin/bootstrap.jar
Using CATALINA_PID:    /var/run/hadoop-httpfs/hadoop-httpfs-httpfs.pid

*I checked the log file as shown above (highlighted in red) and here is
what I found:*
Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/juli/logging/LogFactory
        at org.apache.catalina.startup.Bootstrap.<clinit>(Bootstrap.java:60)
Caused by: java.lang.ClassNotFoundException:
org.apache.juli.logging.LogFactory
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        ... 1 more
Could not find the main class: org.apache.catalina.startup.Bootstrap.
 Program will exit.

*What I believe:*
Tomcat didn't load the jar file correctly.  I checked tomcat-juli.jar and I
can see the LogFactory class file is in there.  I also copied the
tomcat-juli.jar file to the following location and restart the service, but
it still doesn't work.
*
*
*/var/lib/tomcat7/common/classes/*
*/usr/lib/hadoop-httpfs/webapps/webhdfs/WEB-INF/lib/*

*Any suggestions??  What did I miss??  Thanks!!*

T.E.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message