tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thiyagaraj Annamalai <thiyagu.n...@gmail.com>
Subject Re: Fwd: Error starting httpd-2.4.4 with mod_jk on osx
Date Mon, 08 Jul 2013 06:30:36 GMT
Thanks Rainer*. *That was the issue. Problem got solved after pointing to
the correct apxs.

native$ ./configure CFLAGS='-arch x86_64' APXSLDFLAGS='-arch x86_64'
--with-apxs=/usr/local/apache/bin/apxs




On Sun, Jul 7, 2013 at 8:24 PM, Rainer Jung <rainer.jung@kippdata.de> wrote:

> On 07.07.2013 14:27, Thiyagaraj Annamalai wrote:
> > Hi,
> >
> > I'm on OS X 10.8.4. I'm trying to configure mod_jk with httpd-2.4.4 and
> > getting the below error when starting apache.
> >
> > httpd: Syntax error on line 500 of /usr/local/apache/conf/httpd.conf:
> > Syntax error on line 2 of /usr/local/apache/conf/other/httpd-mine.conf:
> >     Cannot load /usr/libexec/apache2/mod_jk.so into server:
> >         dlopen(/usr/libexec/apache2/mod_jk.so, 10):
> >     Symbol not found:
> >         _ap_log_error\n  Referenced from: /usr/libexec/apache2/mod_jk.so
> >         Expected in: flat namespace\n in /usr/libexec/apache2/mod_jk.so
> >
> > How can I fix this?
>
> Sounds like an issue due to mixture between Apache 2.2 and 2.4 ...
>
> > I compiled httpd and mod_jk from the source and both the build went fine.
> >
> > Here's how I built and the conf info.:
> >
> > # compile instructions for httpd
> > # apr, apr-util in srclib/
> > httpd-2.4.4$ ./configure --prefix=/usr/local/apache --with-included-apr
> > --with-  pcre=/usr/local
> > httpd-2.4.4$ make
> > httpd-2.4.4$ sudo make install
> >
> > # compile instructions for mod_jk
> > tomcat-connectors-1.2.37-src$ cd native
> > native$ ./configure CFLAGS='-arch x86_64' APXSLDFLAGS='-arch x86_64'
> > --with-apxs=/usr/sbin/apxs
>
> Here's likely the reason. "/usr/sbin/apxs" was likely installed with
> some Apache 2.2. The correct "apxs" for your 2.4.4 should be somewhere
> under "/usr/local/apache" (bin or build).
>
> > native$ make
> > native$ sudo make install
> >
> > #Content of /usr/local/apache/conf/other/httpd-mine.conf
> > NameVirtualHost *:80
> > LoadModule jk_module /usr/libexec/apache2/mod_jk.so
> >
> > I tried googling and found the above build instructions but still I get
> the
> > error. Thanks in advance for the help!
>
> Regards,
>
> Rainer
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>


-- 
Regards,
Thiyagaraj A.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message