tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: java.lang.NoClassDefFoundError
Date Wed, 10 Jul 2013 03:47:38 GMT
> From: Thomas Edison [mailto:justdoit.thomas.edison@gmail.com] 
> Subject: java.lang.NoClassDefFoundError

> *This is what I see when I start the webhdfs service:*
> Using CLASSPATH:       /usr/share/tomcat7/bin/bootstrap.jar

Whatever script you're using to start Tomcat has a serious error in it: the "Using CLASSPATH"
message should include tomcat-juli.jar in the same directory as bootstrap.jar.  Without that,
Tomcat cannot start.

> *What I believe:*
> Tomcat didn't load the jar file correctly.

No; the startup script didn't set the command line parameters properly, so the JVM could not
find the logging classes.

> I also copied the tomcat-juli.jar file to the following location and restart 
> the service, but it still doesn't work.

A very, very wrong thing to do.  The tomcat-juli.jar must only be in Tomcat's bin directory;
do not attempt to move it or copy it.  Fix the startup script to build the command line properly.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message