tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Walter.Heesterm...@toyota-europe.com
Subject Re: Tomcat 6 and Windows Service
Date Wed, 05 Jun 2013 11:34:39 GMT
Hi,

When I add the arguments to the startup arguments entry, and try to start 
the service

start
-Dcom.sun.management.jmxremote.port=10150
-Dcom.sun.management.jmxremote.ssl=false
-Dcom.sun.management.jmxremote.authenticate=false

Then the following error is given

WARNING: Bootstrap: command 
"-Dcom.sun.management.jmxremote.authenticate=false" does not exist.

Tried "conf/catalina.properties"

I just add the following to the file?

-Dcom.sun.management.jmxremote.port=10150
-Dcom.sun.management.jmxremote.ssl=false
-Dcom.sun.management.jmxremote.authenticate=false

or

com.sun.management.jmxremote.port=10150
com.sun.management.jmxremote.ssl=false
com.sun.management.jmxremote.authenticate=false

Nothing seems to work...

Regards
Walter





From:   Konstantin Kolinko <knst.kolinko@gmail.com>
To:     Tomcat Users List <users@tomcat.apache.org>, 
Date:   03/06/2013 13:32
Subject:        Re: Tomcat 6 and Windows Service



2013/6/3 <Walter.Heestermans@toyota-europe.com>
>
> Hi,
>
> I'm running tomcat as Windows service.
>
> Now I like to add JMX support to the process:
>
> -Dcom.sun.management.jmxremote.port=10150
> -Dcom.sun.management.jmxremote.ssl=false
> -Dcom.sun.management.jmxremote.authenticate=false
>
> Configuring the service
>
>
>
> added the above options to the Java options. The start is then working 
fine and JMX is working fine. But since I made this service the stop 
operation is not working anymore. When I run via console, then I see that 
the stop is complaining on port (used by JMX), already in use. This is 
propably the root cause of the stop not working. Is there a way to specify 
JVM arguments for only the start operation?


The service wrapper comes from Apache Commons Daemon project.
http://commons.apache.org/proper/commons-daemon/

You are better to ask there.

The things that I would try:
a) add those "-D,.." to "start arguments" setting. (The one that
contains a single argument "start" by default).

Maybe it works, maybe not.

b) add those properties to conf/catalina.properties file

It would not work if JVM reads them at startup (before the Bootstrap
class runs), but should work if it reads them at a later time.


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message