tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Tomcat 7 - Getting tld scan error when i compile jsp using Ant task.
Date Thu, 27 Jun 2013 18:08:56 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

To whom it may concern,

On 6/27/13 10:12 AM, Manikandan wrote:
> Bolded sentence only an *info* message. Next sentence is an
> exception after that ant process will get terminated and couldn't
> complete the compilation task.
> 
> [java] 27 Jun, 2013 2:44:47 PM
>> org.apache.jasper.compiler.TldLocationsCache tldScanJar *
>> [java] INFO: At least one JAR was scanned for TLDs yet contained
>> no TLDs. Enable debug logging for this logger for a complete list
>> of JARs that were scanned but no TLDs were found in them.
>> Skipping unneeded JARs during scanning can improve startup time
>> and JSP compilation time. *     [java]
>> org.apache.jasper.JasperException: 
>> file:/home/local/mani/jsp/test.jsp (line: 2, column: 131) File 
>> "/META-INF/struts-tags.tld" not found
> 
> Only required jars in the classpath. As you aware of this, tomcat 7
> only added the functionality of jar scanning for TLDs, due to this
> I have to include *tomcat-api.jar, tomcat-util.jar* in classpath
> because *jasper.jar*has dependency of these two jars.

What does your ANT task look like, and what does your classpath look like?

> The problem is Jar scanning is not reading the *struts-tags.tld*
> file which is present under META-INF/ directory of
> *struts2-core-2.3.12.jar. *This might be the reason for getting the
> error *"File "/META-INF/struts-tags.tld" not found"* * * I have
> came across this 
> site<http://thinkinginsoftware.blogspot.in/2011/10/tomcat-7-scans-all-jars-for-tlds.html>which
>
> 
would says
> If you copy all taglibs that you use into /META-INF, Tomcat won't
> scan all the jars for the tld's.

Nonsense: Tomcat will scan all your JAR files for TLDs.

> Note: Formerly, It was working fine with tomcat 6 version. After
> migrating to the Tomcat 7, am getting this error.

Good to know.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJRzH+3AAoJEBzwKT+lPKRYhNAQALdCegcZvav0maZ+Juon0/7n
PNOOyFySJgnGIybE1LO37B0hiiD0rcnXxm8cSaC1Xskwsm1jSn77X/FBWPz17Xul
gbxzIZw/eZtZcrOE1Z9Xw+R02fxx58h8bQxHjPv2CrGx24ayutQlKoeUJOImdbTK
7uXC+IvrLwV+hZbYz2NhNHMrr9dNSIFFhp4sIrJcFRi3N4BkZzmjWx5/CZZoX5MI
Mg5GxtzZVfrUeerwaov/SUqOXgt0OfBVBJI+A5/MdHMxPktaX3B+wuu37sJ4E86N
xBKGw0ng0nyC2BfX2Y6/6EyhJLu6h/mRQ9oBe6uVm6LI/92etGG3WBoAz57MHrpQ
Ys/jraOYChe7TNjGgx0O6vbSZ+CEE5bDetpwzq+6KxDBzEAqdQsaDfXiIT1NWWwp
nYBhmIRykUpUDhGEqgHx04AmWFFsCV4uMv3O8YtmeouFWA+SdFj12E9ph68pO2oJ
uEHzQMCzrRAUKi0s5QOpXgfwCgiFz5fXm/KZuP7ghqkDdjKwOyFBxpP7iKrShfzs
pudYhsjsc0K+C7CkkKHpimAL45Fzihu2UjyuYIwG8OniMRrLEpHLXCyCWAlz3SNM
EQalEmZ6QLrXrA9LjjzBfU2fvztelKaggkPPqpAGaWYe+EmUVXFSpt8mxjcgkHDr
aPn3dD0rl10SJjEmueri
=4Wu8
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message