tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Piotr Pawłowski <piotr.pawlow...@goyello.com>
Subject RE: binary distribution - how to upgrade ?
Date Thu, 20 Jun 2013 16:54:10 GMT
Hi Bernd,

I think, that the best solution is to 'install' Tomcat manually from binaries available on
Tomcat project.
I do not use repositories on my CentOS/Debian machines, because Tomcat versions available
there are a bit outdated (I need 7.X while in official repos you will not find such).
In addition, read this before upgrade: http://tomcat.apache.org/migration.html .

Best Regards
---
Piotr Pawłowski
System Administrator

T: +48 58 732 77 71
M: +48 698 794 378
E: piotr.pawlowski@goyello.com
S: piotr.goyello.com
W: blog.goyello.com

Goyello Sp. z o.o.
Olivia Gate
Al. Grunwaldzka 472
80-309 Gdańsk
www.goyello.com

CONFIDENTIALITY. This e-mail and any attachments are confidential and may also be privileged.
If received in error, please do not disclose the contents to anyone, but notify the sender
by return e-mail and delete this e-mail (and any attachments) from your system. Goyello accepts
no liability for damage of any kind resulting from the risks inherent in the electronic transmission
of messages.

Spółka zarejestrowana w Sądzie Rejonowym Gdańsk - Północ w Gdańsku, VII Wydział Gospodarczy
KRS pod nr 0000269183, NIP 584-259-98-62, kapitał zakładowy 50.000 zł

________________________________________
From: Lentes, Bernd [bernd.lentes@helmholtz-muenchen.de]
Sent: Thursday, June 20, 2013 18:45
To: 'Tomcat Users List'
Subject: binary distribution - how to upgrade ?

Hi,

i'm fairly new to tomcat. We have a SLES 10 SP4 64bit host, running Tomcat 5.5, which was
provided as a rpm from the distributor.
Our developers need now a more current version, 6 or prefered 7.
I didn't find rpm's for these versions for my OS. So i have to install the binary version
from the tomcat web page.

I read that patches concerning security vulnerabilities are not provided for the binary version.
My question: what do i have to do if i read that version x.x has a security vulnerability
which is closed by version x.y ?
Just install the new version over the old one ? Uninstalling the old one before ? What is
about my webapps ? Are they gone with the installation of the new version ?

Thanks in advance.


Bernd
--
Bernd Lentes

Systemadministration
Institut für Entwicklungsgenetik
Gebäude 35.34 - Raum 208
HelmholtzZentrum münchen
bernd.lentes@helmholtz-muenchen.de
phone: +49 89 3187 1241
fax:   +49 89 3187 2294
http://www.helmholtz-muenchen.de/idg

Wer nichts verdient außer Geld verdient nichts außer Geld

Helmholtz Zentrum München
Deutsches Forschungszentrum für Gesundheit und Umwelt (GmbH)
Ingolstädter Landstr. 1
85764 Neuherberg
www.helmholtz-muenchen.de
Aufsichtsratsvorsitzende: MinDir´in Bärbel Brumme-Bothe
Geschäftsführer: Prof. Dr. Günther Wess Dr. Nikolaus Blum Dr. Alfons Enhsen
Registergericht: Amtsgericht München HRB 6466
USt-IdNr: DE 129521671

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message