tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Colletto <tcolle...@cra.com>
Subject RE: Keystore error trying to use SSL JSSE
Date Thu, 06 Jun 2013 17:35:31 GMT

Hello,

1) keystoreFile (letter F should be in upper case)
2) Use / instead of \
3) Use ${user.home} instead path (and I am not sure c:\ works, you probably need file:///c:/
but ${user.home} is better anyway)
Ilya Kazakevich,



Thank you that worked!
Follow up:
Shockingly it seems that both \ and / in the keystore path work.
${user.home} I think is for linux?  I tried quickly %USERPROFILE%/keystore

And it didn't work, but it works fine with "c:\users\administrator\keystore.jks"






>




THIS MESSAGE IS INTENDED FOR THE USE OF THE PERSON TO WHOM IT IS ADDRESSED. IT MAY CONTAIN
INFORMATION THAT IS PRIVILEGED, CONFIDENTIAL AND EXEMPT FROM DISCLOSURE UNDER APPLICABLE LAW.
If you are not the intended recipient, your use of this message for any purpose is strictly
prohibited. If you have received this communication in error, please delete the message and
notify the sender so that we may correct our records.

-----Original Message-----



>From: Tim Colletto [mailto:tcolletto@cra.com]
>Sent: Thursday, June 06, 2013 7:30 PM
>To: users@tomcat.apache.org
>Subject: Keystore error trying to use SSL JSSE
>
>Hello,
>
>Using the above method I receive the following in the log:
>
>WARNING: [SetAllPropertiesRule]{Server/Service/Connector} Setting
>property 'keystorefile' to 'c:\users\administrator\.keystore' did not
>find
a
>matching property.
>The following is my main config:
>
><Connector port="80" redirectPort="443" protocol="HTTP/1.1"
>               connectionTimeout="20000"/>
>
><Connector port="443" protocol="HTTP/1.1" SSLEnabled="true"
>                maxThreads="150"
>                scheme="https" secure="true"
>                keyAlias="tomcat"
>                keystorefile="c:\users\administrator\.keystore"
>                keystorePass="changeit"
>                acceptCount="100"
>                clientAuth="false" sslProtocol="TLS" />
>
><Connector port="8009" redirectPort="443" protocol="AJP/1.3"/>
>
>I've tried just about every combination of modifications with no luck.
Tried
>different ports. Tried different keystore paths. I did the same steps
>on my windows 7 machine and it all worked fine.
>
>I tried the following protocols:
>protocol="org.apache.coyote.Http11NioProtocol"
>protocol="org.apache.coyote.Http11Protocol"
>
>Nothing worked. I'm at a complete dead end.
>
>I verified that .keystore was ok via keytool -l .keystore
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message