tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chirag Dewan <chirag.dewa...@yahoo.in>
Subject Re: OOME issue in Tomcat 6.0.18(with SSL)
Date Wed, 12 Jun 2013 06:24:19 GMT
Hi Chuck,

Tried the same on 6.0.37 its the same issue. 


I am using JVM 1.6.0.39  and both my client and server are on separate linux x86 machines.

The issue is with one of my client as it seems. HttpClient 3.1. 


A code snippet from both my clients:

3.1 


MultiThreadedHttpConnectionManager myConnectionManager = new MultiThreadedHttpConnectionManager();

HttpClient myClient = new HttpClient(myConnectionManager);

 myConnectionManager.getParams().setMaxConnectionsPerHost(200);
      

 myConnectionManager.getParams().setMaxTotalConnections(200);


For SSL :

 this.sslcontext = SSLContext.getInstance("TLS");
  TrustManager[] arrayOfTrustManager = { new DummyX509TrustManager() };
  this.sslcontext.init(null, arrayOfTrustManager, null);
 SSLSocketFactory localSSLSocketFactory = this.sslcontext.getSocketFactory();



And for 4.1:

     
                PoolingClientConnectionManager pm = new PoolingClientConnectionManager();

                pm.setDefaultMaxPerRoute(200); 
                pm.setMaxTotal(200); 
                HttpClient httpclient = new DefaultHttpClient(pm); 
                try { 
                SSLSocketFactory socketFactory = new SSLSocketFactory(trustStore);

                Scheme sch = new Scheme("https", port, socketFactory); 
                pm.getSchemeRegistry().register(sch);


Chirag



________________________________
 From: "Caldarale, Charles R" <Chuck.Caldarale@unisys.com>
To: Tomcat Users List <users@tomcat.apache.org> 
Sent: Wednesday, 12 June 2013 11:18 AM
Subject: RE: OOME issue in Tomcat 6.0.18(with SSL)
 

> From: Chirag Dewan [mailto:chirag.dewan22@yahoo.in] 
> Subject: OOME issue in Tomcat 6.0.18(with SSL)

> I am using Embedded Tomcat 6.0.18.

Which is nearly five years old.  Many, many fixes (including serious security-related ones)
have gone in since that version was released; you should see if the problem still exists on
the current version of Tomcat 6 or 7.

What JVM version are you using, and what platform are you running on?  (Be precise.)

- Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message