tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Apache Tomcat Native library was not found on the java.library.path
Date Wed, 15 May 2013 18:33:06 GMT
On 15/05/2013 17:03, msyber wrote:
> Hi,
> 
> I need your assistance about APR.
> 
> OS: Centos 5.9
> Tomcat: 6.0.13
> JDK: 1.5.0_22
> echo $JAVA_HOME /usr/java/jdk1.5.0_22
> echo $LD_LIBRARY_PATH /usr/local/apr/lib
> ll /usr/local/apr/lib/
> total 4372
> -rw-r--r-- 1 root root    8367 May 15 16:44 apr.exp
> -rw-r--r-- 1 root root 1344040 May 15 16:44 libapr-1.a
> -rwxr-xr-x 1 root root     972 May 15 16:44 libapr-1.la
> lrwxrwxrwx 1 root root      17 May 15 16:44 libapr-1.so -> libapr-1.so.0.4.6
> lrwxrwxrwx 1 root root      17 May 15 16:44 libapr-1.so.0 ->
> libapr-1.so.0.4.6
> -rwxr-xr-x 1 root root  720241 May 15 16:44 libapr-1.so.0.4.6
> -rw-r--r-- 1 root root 1512166 May 15 16:57 libtcnative-1.a
> -rwxr-xr-x 1 root root    1055 May 15 16:57 libtcnative-1.la
> lrwxrwxrwx 1 root root      23 May 15 16:57 libtcnative-1.so ->
> libtcnative-1.so.0.1.10
> lrwxrwxrwx 1 root root      23 May 15 16:57 libtcnative-1.so.0 ->
> libtcnative-1.so.0.1.10
> -rwxr-xr-x 1 root root  849657 May 15 16:57 libtcnative-1.so.0.1.10
> drwxr-xr-x 2 root root    4096 May 15 16:57 pkgconfig
> 
> catalina.out:
> 
> *INFO: The Apache Tomcat Native library which allows optimal performance in
> production environments was not found on the java.library.path:
> /usr/java/jdk1.5.0_22/jre/lib/i386/client:/usr/java/jdk1.5.0_22/jre/lib/i386:/usr/java/jdk1.5.0_22/jre/../lib/i386:/usr/local/apr/lib
> *
> May 15, 2013 6:02:44 PM org.apache.coyote.http11.Http11Protocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080
> May 15, 2013 6:02:44 PM org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 230 ms
> May 15, 2013 6:02:44 PM org.apache.catalina.core.StandardService start
> INFO: Starting service Catalina
> May 15, 2013 6:02:44 PM org.apache.catalina.core.StandardEngine start
> INFO: Starting Servlet Engine: Apache Tomcat/6.0.13
> May 15, 2013 6:02:44 PM org.apache.coyote.http11.Http11Protocol start
> INFO: Starting Coyote HTTP/1.1 on http-8080
> May 15, 2013 6:02:44 PM org.apache.jk.common.ChannelSocket init
> INFO: JK: ajp13 listening on /0.0.0.0:8009
> May 15, 2013 6:02:44 PM org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=0/10  config=null
> May 15, 2013 6:02:44 PM org.apache.catalina.startup.Catalina start
> INFO: Server startup in 347 ms
> 
> Any idea?

What is the problem? I don't see any ERROR or WARNING level messages in
that output, just INFO messages.

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message