tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Satyendra Singh <satya...@gmail.com>
Subject Re: Tomcat 7.0.39 windows service setenv not used
Date Wed, 24 Apr 2013 20:56:45 GMT
Thanks!, so there is no other way to set these except to put in registry
via tomcat7w.exe.


On Wed, Apr 24, 2013 at 4:50 PM, Konstantin Kolinko
<knst.kolinko@gmail.com>wrote:

> 2013/4/25 Satyendra Singh <satyaadk@gmail.com>:
> > I have created multiple windows services and for one of the service, i
> have
> > -Dcatalina.base=C:\servers\applications\service1
> > -Dcatalina.home=C:\servers\apache-tomcat-7.0.39
> >
> > i have C:\servers\applications\service1\bin\setenv.bat where i have
> >
> > set JAVA_HOME= C:\....
> >
> > Set JAVA_OPTS=-D......
> >
> > set CATALINA_OPTS=-Xms.....
> >
> > running service1 does not seem to use these values, it only use those
> that
> > i can see at  tomcat7w.exe on this service.
> >
>
>
> As documented,
> [quote]
> All the environment variables described here and the "setenv" script are
> used only if you use the standard scripts to launch Tomcat. For example, if
> you have installed Tomcat as a service on Windows, the service wrapper
> launches Java directly and does not use the script files.
> [/quote]
>
> http://tomcat.apache.org/tomcat-7.0-doc/RUNNING.txt
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message