tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael-O <1983-01...@gmx.net>
Subject Re: Unable to start tomcat (JDBC-ORACLE CONNECTIVITY ISSUE WITYH OCI8 DRIVER using oracle 11g client.)
Date Sat, 06 Apr 2013 09:05:27 GMT
Am 2013-04-06 10:30, schrieb dkumar@ccilindia.co.in:
> Dear All,
>
> JDBC-ORACLE CONNECTIVITY ISSUE WITYH OCI8 DRIVER using oracle 11g client..
> I am getting below error when i m trying to access oracle db using oracle
> 11g client. It works with earlier oracle client versions. how do i resolve
> this.  is there any issue with version of ojdbc6.jar that i am using??? I
> cant use thin driver since its an old application for which i dont have
> source files.
>
> Apr 6, 2013 1:00:59 PM org.apache.catalina.core.StandardWrapperValve
> invoke
> SEVERE: Servlet.service() for servlet jsp threw exception
> java.lang.UnsatisfiedLinkError: no ocijdbc9 in java.library.path


1. This is not a Tomcat problem but a library path problem.
2. Use the native Java driver, there's no need for the OCI version.
3. Read the Oracle docs how to use OCI8 with JDBC.

Michael

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message