tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Flaherty <pflah...@rampageinc.com>
Subject Re: Cannot access my app after Tomcat 7.0.28
Date Tue, 05 Mar 2013 23:45:23 GMT

On Mar 5, 2013, at 4:44 PM, Howard W. Smith, Jr. wrote:

> On Tue, Mar 5, 2013 at 1:04 PM, Patrick Flaherty <pflahrty@rampageinc.com 
> >wrote:
>
>> Hi,
>>
>> When using any build of Tomcat *post* 7.0.28, I cannot access my  
>> app ! The
>> app comes up as it does in 7.0.28 (which works) and
>> logs look the same (no errors). I just can't do an http call to the
>> server. A packet trace shown the tcp connect (3 way handshake)
>> and then no response to Get / HTTP/1.1. The index.jsp in ROOT is a  
>> jsp
>> containing a redirect to my app.
>>
>> <%
>>        response.sendRedirect("/myapp/**index.do");
>> %>
>>
>> Did something change in 7.0.29 and beyond that might cause this  
>> behavior?
>> I looked through the changelog and nothing jumped
>> out at me.
>>
>> Thanks
>> Pat
>>
>>
> You may want to share more details about your environment/ 
> configuration. Is
> it possible that your 7.0.29+ configuration is missing some  
> configuration
> that exists in your 7.0.28 configuration? You also may want to share  
> the
> steps you took while migrating to, installing, or configuring your  
> 7.0.29+
> environment.
I downloaded the 32 bit zip version of the tomcat. Change the tcp port  
in the server.xml file from 8080 to 80.
The platform is Windows 7 64 bit. I run the service.bat file to  
install it as a service. (Service install Tomcat7).
I did not replace the index.jsp this time and did not introduce my  
war. I then started the service and I was able
to get to the standard Tomcat ROOT page. So I know Tomcat works. I  
stop tomcat, drop my war file in and
restart tomcat. I go to standardout.log and I see my app is completely  
up and is running, as it prints an info
line every 5 minutes to stdout. At this point I cannot get to the ROOT  
page (Now has the stock index.jsp) nor
can I get to my app by typing the URL consisting of the ip address of  
the computer +/myapp (e.g. http://192168.2.2/rrmt).
Both just hang in the browser. Now I just noticed that on this 4 core  
server, tomcat7.exe *32 is using 25% CPU.
My app *seems happy printing it's server is up message to the  
stdout.log.

Same war works in 7.0.27 and a few tomcats prior but every tomcat  
fails as described above for every version post 7.0.27 up
through 7.0.37. I have tried them all. It must be something in my code  
but I perplexed. The act of adding my war causes the problem.
I checked the changelog for tomcat and cannot see anything that would  
cause this.

Any thoughts appreciated.
Thanks
Pat


>
>
>
>>
>> ------------------------------**------------------------------ 
>> **---------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.**apache.org<users-unsubscribe@tomcat.apache.org

>> >
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message