tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From TVFoodMaps <tvfoodm...@gmail.com>
Subject Issue with Connections
Date Wed, 06 Feb 2013 16:35:32 GMT
Hi,

My website is setup using apache 2, mod jk 1.37 and tomcat 6.  Most of the
connector settings are set to defaults and things normally run pretty well.
 However during certain spikes in traffic my server seems to hang by what
appears to be caused by "leaking connections".  What I see is about 250
rows like this from a netstat:

tcp        1      0 ::ffff:127.0.0.1:8009       ::ffff:127.0.0.1:48387
 CLOSE_WAIT
tcp        1      0 ::ffff:127.0.0.1:8009       ::ffff:127.0.0.1:48309
 CLOSE_WAIT
tcp      689      0 ::ffff:127.0.0.1:8009       ::ffff:127.0.0.1:48423
 CLOSE_WAIT
tcp      686      0 ::ffff:127.0.0.1:8009       ::ffff:127.0.0.1:48413
 CLOSE_WAIT

I also am see a lot of these:

tcp        1      0 ::ffff:127.0.0.1:49261      ::ffff:127.0.0.1:8080
CLOSE_WAIT
tcp        1      0 ::ffff:127.0.0.1:52836      ::ffff:127.0.0.1:8080
CLOSE_WAIT
tcp        0      0 ::ffff:127.0.0.1:58262      ::ffff:127.0.0.1:8080
TIME_WAIT

(Note the application makes direct calls to port 8080 for a specific API
I'm using (SOLR)).

I'm really not sure which is actually causing the problem, but I was hoping
for some guidane on which settings I should look into tweaking.


-- 
Thanks,
Frank
http://www.tvfoodmaps.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message