tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Quentin Spencer <qspen...@gmail.com>
Subject Re: Running Tomcat in Debug Mode on Windows 7
Date Thu, 07 Feb 2013 15:35:27 GMT
Thank you Dan, I did see that FAQ and bullet. I tried adding the
lines"-Xdebug
-Xrunjdwp:transport=dt_socket,address=8000,server=y,suspend=n" to the Java
Options box in the Java tab of the Common Daemon Service manager but Tomcat
wouldn't start after I did this. If someone could give me more detailed
instructions on how to implement the instructions in that document I would
really appreciate it.


On Thu, Feb 7, 2013 at 9:27 AM, Daniel Mikusa <dmikusa@vmware.com> wrote:

> On Feb 7, 2013, at 9:14 AM, Quentin Spencer wrote:
>
> > I want to run TomCat in debug mode so I can debug my servlet from
> Eclipse.
> >
> > I installed TomCat 7 using the Windows Installer. It was installed as a
> > service, managed by the Commons Daemon Service Manager. It runs servlets
> > fine (i.e., no problems with normal TC operation).
> >
> > I did the following:
> >
> > 1. Added "jpda start" as Arguments in the Startup tab in the Daemon
> Service
> > Manager.
>
> This is not right.  See the second bullet point listed here for the
> correct instructions.
>
>   https://wiki.apache.org/tomcat/FAQ/Developing#Q1
>
> Dan
>
> >
> > 2. Created a custom Debug Configuration in Eclipse (Java EE version, Juno
> > Service Release 1) with:
> >
> > Connection Type: Standard (Socket Attach)
> > Host: localhost
> > Port: 8000
> > Allow termination of remote VM: unchecked
> >
> > When I run this Debug Configuration I get "cannot connect to JVM,
> > connection refused".
> >
> > In the Tomcat log file I see:
> >
> > loading jvm 'C:\Program Files\Java\jre6\bin\client\jvm.dll'
> > [2013-02-07 08:13:13] [debug] ( javajni.c:660 ) Jvm Option[0]
> > -Dcatalina.home=C:\Program Files\Apache Software Foundation\Tomcat 7.0
> > [2013-02-07 08:13:13] [debug] ( javajni.c:660 ) Jvm Option[1]
> > -Dcatalina.base=C:\Program Files\Apache Software Foundation\Tomcat 7.0
> > [2013-02-07 08:13:13] [debug] ( javajni.c:660 ) Jvm Option[2]
> > -Djava.endorsed.dirs=C:\Program Files\Apache Software Foundation\Tomcat
> > 7.0\endorsed
> > [2013-02-07 08:13:13] [debug] ( javajni.c:660 ) Jvm Option[3]
> > -Djava.io.tmpdir=C:\Program Files\Apache Software Foundation\Tomcat
> 7.0\temp
> > [2013-02-07 08:13:13] [debug] ( javajni.c:660 ) Jvm Option[4]
> > -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
> > [2013-02-07 08:13:13] [debug] ( javajni.c:660 ) Jvm Option[5]
> > -Djava.util.logging.config.file=C:\Program Files\Apache Software
> > Foundation\Tomcat 7.0\conf\logging.properties
> > [2013-02-07 08:13:13] [debug] ( javajni.c:660 ) Jvm Option[6]
> > -Djava.class.path=C:\Program Files\Apache Software Foundation\Tomcat
> > 7.0\bin\bootstrap.jar;C:\Program Files\Apache Software Foundation\Tomcat
> > 7.0\bin\tomcat-juli.jar
> > [2013-02-07 08:13:13] [debug] ( javajni.c:844 ) argv[0] = jpda
> > [2013-02-07 08:13:13] [debug] ( javajni.c:844 ) argv[1] = start
> >
> > Any help would be appreciated. And yes, I have spent several hours
> googling
> > this issue but can't find a solution
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message