tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Problem with nsapi_redirect.so (1.2.37) on iPlanet 7.0.15 and Solaris 11
Date Tue, 19 Feb 2013 19:41:48 GMT
Andy Wang wrote:
> On 02/19/2013 12:11 AM, Mladen Turk wrote:
>>
>> Did you tried to check the ulimit.
>> Seems like webservd once when switched to non privileged user cannot 
>> create threads
>> either because of some security settings or lack of resources.
>>
>>
> 
> I'm not so sure that this sequence is what's occurring.
> When the jk_init function is called, the non-privileged webservd process 
> hasn't actually been spawned yet.  As far as I can tell, it's still 
> running within the root owned webservd parent process.
> 
> So at this point, I don't think it's switched to the non-privileged user 
> yet.
> 
> Of course that still doesn't make sense why the root user wouldn't be 
> able to create a thread with systhread_start.
> 

Hi.
I do not really understand the problem here, so this may be relevant or not. I don't know,

but I'm offering this free.
I remember reading that in its start sequence, Apache first runs through a complete 
startup sequence, reading all configuration files, loading and starting all add-on modules

etc.., all in the one startup "master" instance.
Then it throws everything away and immediately starts up again, goes again through the 
same sequence and only then starts any "children" processes/threads.
Again if I remember correctly, this is done to allow Apache to check that all 
configurations are correct, that all its required modules can be loaded etc., before 
starting "for real".  Maybe there is a clue in there for you.  And maybe not.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message