tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <>
Subject Re: Is error with Bamboo Sonar plugin because of Tomcat 6 instead of Tomcat 7?
Date Wed, 16 Jan 2013 20:21:11 GMT
Hash: SHA256


On 1/16/13 2:38 PM, KARR, DAVID wrote:
> We're running Bamboo with Tomcat 6.  We're trying to add the Sonar
>  plugin.  When we try to configure it, we get this exception when
> it tries to call that specific Tomcat API.  The theory that I'm 
> exploring is that the plugin requires Bamboo to be running with 
> Tomcat 7, not Tomcat 6.

Shouldn't it be very easy to check the requirements of the plug-in?
Perhaps, on a "Bamboo Sonar Plug-in Requirements" page? I wasn't able to
find anything quickly on Google, but then that plug-in has either not
been supported since 2010 (Atlassian) or merely requires Bamboo 3.3 or
higher, which only supports running under Tomcat 5.5 or 6.0. So, your
suggestion that upgrading to Tomcat 7 may fix your problem seems unlikely.

> I don't want to try moving to Tomcat 7 unless we have some
> assurance that that will resolve the problem.

I wouldn't move to Tomcat 7 until Bamboo says they support it.

Back to the original problem:

> Caused by: java.lang.IllegalAccessException: Class
> com.atlassian.activeobjects.bamboo.ConnectionHandler can not access
> a member of class
> org.apache.tomcat.dbcp.dbcp.PoolingDataSource$PoolGuardConnectionWrapper
> with modifiers "public" at
> sun.reflect.Reflection.ensureMemberAccess( at
> java.lang.reflect.Method.invoke( at
> com.atlassian.activeobjects.bamboo.ConnectionHandler.delegate(

Is that class (com.atlassian.activeobjects.bamboo.ConnectionHandler) a
part of Bamboo or the Sonar plug-in? Since it doesn't have any "sonar"
name in it, I'd suspect it's part of Bamboo and not the plug-in.

If you gave us the whole stack trace, maybe we'd be able to guess at
the actual problem and give you some suggestions.

- -chris
Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
Comment: GPGTools -
Comment: Using GnuPG with undefined -


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message