tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Tomcat slow during startup >= 7.0.28
Date Mon, 14 Jan 2013 15:44:16 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Conrad,

On 1/14/13 9:11 AM, Conrad Kostecki wrote:
> I've noticed, that Tomcat got much slower during startup. When
> using a Version > 7.0.27 (+ Oracle JDK 7), it takes much longer.
> 
> Jan 14, 2013 2:12:40 PM
> org.apache.catalina.core.AprLifecycleListener init INFO: Loaded APR
> based Apache Tomcat Native library 1.1.24 using APR version 1.4.6. 
> Jan 14, 2013 2:12:40 PM
> org.apache.catalina.core.AprLifecycleListener init INFO: APR
> capabilities: IPv6 [true], sendfile [true], accept filters [false],
> random [true]. Jan 14, 2013 2:12:40 PM
> org.apache.catalina.core.AprLifecycleListener initializeSSL INFO:
> OpenSSL successfully initialized (OpenSSL 1.0.1c 10 May 2012) Jan
> 14, 2013 2:12:40 PM org.apache.coyote.AbstractProtocol init INFO:
> Initializing ProtocolHandler ["http-apr-8080"] Jan 14, 2013 2:12:40
> PM org.apache.coyote.AbstractProtocol init INFO: Initializing
> ProtocolHandler ["http-apr-8443"] Jan 14, 2013 2:12:40 PM
> org.apache.coyote.AbstractProtocol init INFO: Initializing
> ProtocolHandler ["ajp-apr-8009"] Jan 14, 2013 2:12:40 PM
> org.apache.catalina.startup.Catalina load INFO: Initialization
> processed in 723 ms Jan 14, 2013 2:12:40 PM
> org.apache.catalina.core.StandardService startInternal INFO:
> Starting service Catalina Jan 14, 2013 2:12:40 PM
> org.apache.catalina.core.StandardEngine startInternal INFO:
> Starting Servlet Engine: Apache Tomcat/7.0.32
> 
> After this Step, with a newer version, it can take several minutes,
> until it continues. During this "pause", I can see, that the disk
> i/o is pretty high.

Thread dump?

> When I switch back to an older version < 7.0.27, this goes much 
> faster. It just takes seconds.
> 
> I am using a stock default config, only added
> "URIEncoding="UTF-8"". Tested with Windows 7 Professional and
> Ubuntu 12.04.
> 
> I don't know where to start for debugging this problem. Any Ideas?

Take a thread dump or two. I suspect that Tomcat is scanning more JAR
files than it used to due to the clarifications of certain behaviors
by the servlet EG. If Tomcat is spending a long time scanning JAR
files, there are a number of ways to stop that from happening. Let's
confirm before we start changing configuration, though.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iEYEAREIAAYFAlD0J9AACgkQ9CaO5/Lv0PBlagCcDTyuInpq917lXKvK1tJKMU+k
1fcAoKBVk1l5KBqKIz23jRB8aeABg2ig
=o1KK
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message