tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shakun Nag <shakun....@gmail.com>
Subject Tomcat 5.5.9 compatibility with Java 1.7
Date Fri, 28 Dec 2012 08:41:22 GMT
Hi,

I am working on a web application which has been build on JDK/JRE 1.6.0_06
and has been deployed on Tomcat 5.5.9 server. This application is on
production since 2008. There is a plan to upgrade JDK/JVM to 1.7.0_07. My
concern is that after the upgrade of JDK and JVM, will the application be
deploying and running successfully on the aforesaid version of Tomcat i.e.
5.5.9 with out any issues? There is no information available either on
java<http://www.javaranch.com/> or
on Apace Tomcat site regrading the compatibility of java 1.7 with tomcat
5.5.9. The only information I was able to collect is that Tomcat 5.5.9
requires minimum 1.4 version. There are no resources available for the
maximum compatible version.

Please let me know if somebody has done such upgrade of their application
or is aware of any known compatibility issue. I am afraid that we will need
to upgrade tomcat as well along with upgrading to java 1.7. Do let me know
if any more information is required.

PS: This is an urgent request to evaluate the feasibility. So we don't have
much time, budget and resources to carry out a POC.

Thanks,
Shakun

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message