tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yuri E <themachinesickn...@gmail.com>
Subject Re: I can only access Tomcat 7 when running via console (startup.bat)
Date Thu, 06 Dec 2012 23:21:23 GMT
>2012/12/6 Daniel Mikusa <dmikusa@vmware.com>:
>> On Dec 6, 2012, at 11:19 AM, Yuri E wrote:
>>
>>> so I decided to install Tomcat through the .exe installer. First, I
stopped
>>> Tomcat by closing the console window opened in the startup, and then I
>>> installed Tomcat as service using the .exe.
>>> I restarted the computer, and Tomcat automatically started. Good. But
when
>>> I went to access my web app again using router's IP, I couldn't. Then, I
>>> tried to access Tomcat's Welcome Page using Firefox (
http://localhost:8080),
>>> and everything was ok.
>>
>> If Tomcat's welcome page is accessible then Tomcat is up and running.
 It's likely that you application failed to deploy.
>>
>> Have you looked at the server logs and your application logs to see if
there were any problems?
>>
>
>+1
>
>The description above sounds like the OP installed a brand new fresh
>copy of Tomcat, but have not deployed a copy his app on it.
>
>There is "manager" webapp available in the standard distributive, that
>allows one to see what apps are deployed.

With Tomcat running as service, I tested my app with
"localhost:8080/[myapp]/[servlet]", and it worked,

What basically happens is that I can't access Tomcat (running as service)
from web (outside my router subnet) . In all other ways, the connection
works.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message